Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jan 18, 2008, 5:03 AM   #1
Junior Member
 
Join Date: Dec 2007
Posts: 7
Default

I have a battery problem with my finepix f30 digital camera.

First of all I have to tell you that the charger that was in the box doesn't charge the camera! So I decided to buy an external charger.

So after I charge the battery, I put it back to the camera and everything is fine! The camera is working perfectly..

When I'm trying to use my camera after 10 hours the camera doesn't turn on! I check the battery and I see that it's empty!!

Have you faced a similar problem? What do you think is happening here?

Thanx a lot for your time,
a desperate fujifilm user..
Tax07 is offline   Reply With Quote
Sponsored Links
Old Jan 18, 2008, 10:13 AM   #2
Senior Member
 
Join Date: May 2005
Posts: 1,063
Default

It could be that the charger you purchased is not fully compatible with the battery for your camera. It might be able to partially charge the battery. Or, it's possible that your battery has gone bad. I have the Fuji 9000 which runs on AA batteries. I bought a bunch of Energizer rechargeables that after a few months of use would run down within a week just sitting in the camera. I purchased three sets of Duracell batteries, and their performance is unbelievable compared to what I was experiencing previously.

There are a number of battery suppliers online that will enable you to enter your camera make/model and they will recommend what they have that is compatible. You might want to look at getting a new battery and charger that are advertised as being compatible.
jphess is offline   Reply With Quote
Old Jan 18, 2008, 4:44 PM   #3
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Tax,

You didn't exactly tell the whole story here, did you? Like the fact that you bought the camera used on ebay...

Did you follow the advice I gave you previously? If you recall, I told you the most likely cause was the battery.

http://forums.steves-digicams.com/fo...834045#p834045

Did you buy a new battery?

the Hun

rinniethehun is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:19 AM.