Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Mar 5, 2008, 12:11 PM   #1
Junior Member
 
Join Date: Dec 2005
Posts: 6
Default

I bought my 2nd S9600 3 weeks ago, and already I have a little bit of dust inside the display. It doesn't affect pictures, but it's quite anoying. Does anyone else have/had this problem? I had one S9600 before this, 1 year old and the display wasn't dusty at all.
Thanks for Your answers!
darkovsky is offline   Reply With Quote
Sponsored Links
Old Mar 21, 2008, 2:59 PM   #2
Junior Member
 
Join Date: Dec 2005
Posts: 6
Default

So, no one with this problem? Till today, the display is even worse. Any recommendations?
darkovsky is offline   Reply With Quote
Old Mar 21, 2008, 8:38 PM   #3
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Sorry, but I don't have your particular camera model, nor have I heard of your particular problem. When you say dusty display, do you mean you see spots or something inside the EVF? Or you see something on the LCD? Since it doesn't affect the pics, it must not be on the sensor or the inside of the lens. You say it is getting worse...I don't think dust can multiply. Maybe you have mold growing inside the cam?

Sinice you've just bought the camera, you should be able to return it for exchange.

Good luck.

the Hun

rinniethehun is offline   Reply With Quote
Old Mar 24, 2008, 4:15 PM   #4
Junior Member
 
Join Date: Dec 2005
Posts: 6
Default

Thanks for your answer. So, the dust is not in the sensor, nor in the EVF, it is inside the display. When I say it's gettin worse, I mean that more dust came in. I will try to take a picture of the display tomorrow
darkovsky is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:38 AM.