Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Feb 22, 2009, 8:32 AM   #1
Junior Member
 
Join Date: Jan 2006
Posts: 4
Default

I bought a Fuji S602Z when they came out. I never used the CF slot. When I tried to use it a few months ago it kept giving me the message (card not initialized and card error), changed cards still got the same message. contacted Fuji and they told me to contact Fuji repair in St.Petersburg, Florida. I did and they told me the camera was bad and it was better to buy another camera. I have taken care of this camera and it has never been dropped. I have tried using Lexar and San Disk cards all with the same message. Guess I will have to go invest in a Canon or Nikon after spending close to $600 for the Fuji. I did a lot of research before buying and decided to purchase after reading Steves evaluation. It takes great pictures but I need more storage than the old type smart media can give me and you can't find in stores anymore. If anyone has a solution to this problem (other than buying a new camera) I would like to hear it.
Unclewiggley is offline   Reply With Quote
Sponsored Links
Old Feb 22, 2009, 2:15 PM   #2
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Let's see if I got this right...you bought a camera 7 years ago, and never used one of the memory slots. Then you go out and buy a CF card on ebay (you forgot to tell us that part), plop it in that previously never used memory slot, and it didn't work - surprise, surprise. Now you want to bash Fuji? For what? Not having better quality control in 2001? For not giving you a brand new camera in 2009? You want to blame Steve for talking you into spending $600?

If I'm not mistaken, your camera still works fine with SM, so what's your beef?

Come back in 7 years and let us know how your Nikon or Canon is doing. I'm sure it will be working just like the day you took it out of the box.

The Hun

rinniethehun is offline   Reply With Quote
Old Mar 13, 2009, 3:29 PM   #3
Senior Member
 
bernabeu's Avatar
 
Join Date: Jan 2005
Posts: 990
Default

my minolta srt-201 works just like the day i took it from the box



:blah:
bernabeu is offline   Reply With Quote
Old Mar 13, 2009, 6:04 PM   #4
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Where's the CF slot on that thing?

the Hun

rinniethehun is offline   Reply With Quote
Old Mar 17, 2009, 2:48 PM   #5
Senior Member
 
bernabeu's Avatar
 
Join Date: Jan 2005
Posts: 990
Default

mounted on my minolta km-7d

also on my fuji s7000

:homey:
bernabeu is offline   Reply With Quote
Old Mar 17, 2009, 9:44 PM   #6
Senior Member
 
Join Date: Jan 2007
Location: Decatur, GA
Posts: 2,053
Default

I still have a panasonic Superdisc 1.3MPdigital camera complete with 2x 120MB discs. It still works like its band new but it was always a very SLOW camera. Got it in 2001. Have had 4 cameras since but sold the first 3 all along the way..... Olympus C700, C740 Fuji S5100 and Fuji S9100. Have the Fuji S9100 as a backup should the Sony A200 stop working.

Current cameras are a weatherproof Olympus camera SW720? with 5x zoom and the Sony A200. 2GBUltra II sandisc, 2GB Kingston standard, 4GB 100x PQI, 8GB 133x transcend, 16GB 133x transcend CF cards and 3x1GB xD cards (2xM series, 1xH series).

My uncle still has his original digtial camera the Olympus UZ2100 or is it the 2100UZ with a 10x zoom. He tells me has close to 30,000 frames on it. Still has his original 2x 32MB smart media cards for it. 32MB man that camera is old..........

dave
Photo 5 is offline   Reply With Quote
Old Oct 5, 2009, 2:20 AM   #7
Junior Member
 
Join Date: Oct 2009
Posts: 1
Default compact flash doesn't work in my 602z either

compact flash doesn't work in my 602z either and i get same error as you when i try to insert it. also, if you look carefully at diagram inside media compartment it tells you to insert cf with lip (for pulling it out later) down.
but cf card only goes in with lip up. so it looks like fujitsu screwed up & put the guides that force how the card goes in backwards. end result of this would be all electrical pin connections between card and camera host are wrong. the tone of fujitsu's response to you sounds like they are screwing us. but this can't be the case, because i know fujitsu is honorable and i hope they read this and offer to do the right thing and fix the defect in the 602z for us free of charge. when the 602z first came out majority of users probably used smartmedia and cf insertion defect was not noticed, but now smartmedia is scarce, while cf is abunduant.
josephbacci is offline   Reply With Quote
Old Aug 3, 2010, 11:52 AM   #8
Junior Member
 
Join Date: Aug 2010
Posts: 1
Default S602z

I bought my wife a S602Z many years ago and have always used CF cards and rarely Smart Media. Never a problem. Zoom switch packed it in a few yrs ago (out of warranty) and we had it repaired. Was well worth it. She still loves this camera.
joegigs is offline   Reply With Quote
Old Aug 3, 2010, 12:42 PM   #9
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Joe-

Welcome to the Forum. We're pleased that you dropped by.

Yes, I still use my Fuji S-602 and it still performs well. There are lots of S-602 cameras still in use today.

Sarah Joyce
mtclimber is offline   Reply With Quote
Old Aug 5, 2010, 1:30 AM   #10
Member
 
Join Date: Apr 2010
Location: Portholland, Cornwall, UK
Posts: 42
Default

What size card are you trying to use? The 602 has a card size limit of 2gb due to the old FAT16 file system, anything bigger will return an error.
Cornwall David is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:35 PM.