Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Feb 13, 2004, 10:25 PM   #1
3xv
Junior Member
 
Join Date: Jan 2004
Posts: 13
Default S7000 Battery drain problem

Anyone else having a similar problem. I use the standard 16mb XD and Sandisk Ultra II 256mb CF card in it and after an hour or two of not using the camera (in the off position) the 1800mah nimh batts. are discharged. Just wondering if it's normal or not.
3xv is offline   Reply With Quote
Sponsored Links
Old Feb 15, 2004, 8:10 AM   #2
Member
 
Join Date: Jun 2003
Posts: 36
Default

You may have one of the early models that has that problem.
http://www.dcviews.com/press/Fuji-S7000-rec.htm
ps34109 is offline   Reply With Quote
Old Mar 1, 2004, 7:51 PM   #3
Junior Member
 
Join Date: Mar 2004
Posts: 5
Default

Had the same problem with Sandisk CF card.
I switched to a Lexar 256 CF card and no problem.
Batteries have a long camera life now.
Wallace is offline   Reply With Quote
Old Mar 1, 2004, 8:43 PM   #4
hst
Senior Member
 
Join Date: Jul 2003
Posts: 182
Default I had the same issue

I used a Sandisk Ultra II and it caused the battery to drain. I returned the camera and it was replaced by Dell. Unfortunately they sent another with the same issue. The Serial Numbers before 34L60001 were produced before 12-15-04 and they had the problem. Fuji asked me to return it directly to the Dell because if they had it would take them a while to get it back to me if I sent it to them. Both companies were great and the return was easy on both cameras. Only problem now, I am without a camera and afraid to buy another one for a few months until the older inventory clears out.
hst is offline   Reply With Quote
Old Mar 1, 2004, 9:10 PM   #5
3xv
Junior Member
 
Join Date: Jan 2004
Posts: 13
Default

Unfortunately Bestbuy is not as compliant with electronic returns
3xv is offline   Reply With Quote
Old Mar 1, 2004, 10:13 PM   #6
hst
Senior Member
 
Join Date: Jul 2003
Posts: 182
Default Call Fuji

Here is their info. They were great on the phone and they said they would fix or replace the camera if I sent it to them:

Fuji Photo Film USA, Inc.
1100 King George Post Rd.
Edison NJ 08837
Attn.: Repair Dept.
Phone: 800-659-3854 (x3461) Hours: 9:00 am - 8:00 pm EST

They answered the phoneright away and told me it would take a few weeks to get it back after it was sent in. I have heard other who have sent theirs in and they have fixed the issue.
hst is offline   Reply With Quote
Old Mar 2, 2004, 2:56 PM   #7
Junior Member
 
Join Date: Nov 2003
Posts: 2
Default

I had one of the early models and even though I don't have any CF cards I sent the camera back to Fuji, so when I did purchase a card I wouldn't have any problems, It came back in just under a week, on the first try out of my camera, after a couple of shots the readout of my settings disappeared, just the once, but I thought I could live with that and then after a week I had a photo opportunity that needed the flash, it didn't work, it's now back at Fuji, with a bit of luck it'll be back tomorrow and I can then try this Cf card I've bought for it.[color=white][/code]
al-m is offline   Reply With Quote
Old Mar 3, 2004, 6:37 AM   #8
3xv
Junior Member
 
Join Date: Jan 2004
Posts: 13
Default

Thank you for the help. I will try to contact them and see what happens
3xv is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:27 AM.