Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jul 14, 2004, 2:27 PM   #1
Junior Member
 
justinmikehunt's Avatar
 
Join Date: Jun 2004
Posts: 19
Default

So I've had a 3800 for about a year and a half. Once you adjust to some of it's quirks in different situations, I think it's a great camera. I bought it because of it's zoom, and I'm still happy with the purchase.

Anyways, recently, this problem has come up.

Take the bottom of following control dials:



The one with positions for Manual Record, Portrait, Auto and Movie...

It's randomly cut half it's functionality. When I have it on Manual or Portrait, it works as manual, and when i have it on Auto or Movie, it works as movie. I've been able to make it by with just these two settings, but it would be nice to have all of them.

Any thoughts? It didn't take any blows that I'm aware of. I used it, put it in my case, then when i used it again it was screwed up.
justinmikehunt is offline   Reply With Quote
Sponsored Links
Old Jul 15, 2004, 11:46 AM   #2
Member
 
Join Date: Jun 2002
Posts: 88
Default

IF you check out http://www.pbase.com/image/29746211 and http://www.pbase.com/image/29746210 , you'll see the how the switching is actually done. Plastic cams operate PCB mounted swithes. My guess is either one of the switches is sticking or the body section has gone slightly out of alignment. I haven't added all the service notes for the pix, but getting the S3800 apart is EASY and a pleasure.
See www.digsys.com.au/s602/s602.html for links to various Fuji models and service notes. At worst, IF the switch is broken? , spare parts from Fuji are cheap!
JKirk
jkirk@oz is offline   Reply With Quote
Old Jul 25, 2004, 6:39 PM   #3
Junior Member
 
Join Date: Jul 2004
Posts: 10
Default

Hey Jkerk,

Were did you get thoes pictures? Also any advice on working on the zoom and finding part replacements for the end zoom for the 3800? I droped mine awhile back and it bent the telephoto zoom on it and wont work, I got it off and I tried takeing it apart, it was easy but couldent get to the front of the camera.

Any how,
Thanks for any advice.


junglereptiles is offline   Reply With Quote
Old Jul 27, 2004, 11:34 AM   #4
Member
 
Join Date: Jun 2002
Posts: 88
Default

Quote:
Were did you get those pictures?
LOL, I made them :-) .. I've repaired heaps of Fuji's. I have dozens more service help pages, but been too busy to post them, unfortunately. Actually, I successfully repaired a 3800 zoom a few weeks ago. It is a DAMN FINE engineered section. Such a crying shame they totally stuffed it when they designed the 4900,6900,S602,S7000,,, A terrible step back. THEN the bastids won't sell JUST the lens assembly, we have to buy it with the CCD .. at US$300+ .. idiots.
You shouldn't have ANY problems getting the lens out and apart, I've done quite a few now. I love working on the S3800,2800. Just undo all screws and remember where they go :-) .. AND as a BONUS !! You DON'T have to run an expensive ZOOM calibration program if you split the lens, as per the S602++ etc
One day I'll finish the notes on the URL ... one day :-)
JKirk
jkirk@oz is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:44 AM.