Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jul 19, 2005, 2:36 PM   #11
Junior Member
 
Join Date: Jul 2005
Posts: 10
Default

i am having the exact same problem with my f700. sometimes the lcd/picture comes out black and white, and sometimes it's purple and green like the one you posted. once in a while i tirn it on and it works fine for a bit. i bought it in march 04 and it has worked perfectly until now. i really liked the camera and probably would have kept it another several years had this not happened. i'm calling fuji right now to see what's up. i'll keep you all posted.
jnev is offline   Reply With Quote
Old Jul 21, 2005, 12:23 AM   #12
Junior Member
 
Join Date: Jul 2005
Posts: 10
Default

i called fujifilm and lady i talked to didn't argue with me at all about the problem, she even said that they will most likely fix it for free after taking a look at it. i'll be mailing it tomorrow. i'll keep you all posted.
jnev is offline   Reply With Quote
Old Jul 28, 2005, 3:00 PM   #13
Junior Member
 
Join Date: Jul 2005
Posts: 7
Default

jnev wrote:
Quote:
i called fujifilm and lady i talked to didn't argue with me at all about the problem, she even said that they will most likely fix it for free after taking a look at it. i'll be mailing it tomorrow. i'll keep you all posted.

Hi,

Please keep me posted. I've had mine about as long as you have, and this has started happening today. Typical, I go on holiday at the end of the month :sad:.

I'll be taking mine in on saturday, but seeing as it's out of warranty I'll have to pay, but not sure how much.
WheelieBoy is offline   Reply With Quote
Old Jul 28, 2005, 3:00 PM   #14
Junior Member
 
Join Date: Jul 2005
Posts: 7
Default

jnev wrote:
Quote:
i called fujifilm and lady i talked to didn't argue with me at all about the problem, she even said that they will most likely fix it for free after taking a look at it. i'll be mailing it tomorrow. i'll keep you all posted.

Hi,

Please keep me posted. I've had mine about as long as you have, and this has started happening today. Typical, I go on holiday at the end of the month :sad:.

I'll be taking mine in on saturday, but seeing as it's out of warranty I'll have to pay, but not sure how much.
WheelieBoy is offline   Reply With Quote
Old Aug 5, 2005, 3:03 PM   #15
Junior Member
 
Join Date: Sep 2003
Posts: 18
Default

Spoke with the customer service dept at ritz. While the f450 does a nice job as a p&s it does not have any of the advanced features that i got the f700 for. they could get me a refurbished f700 but i'm a little gunshy after the way the last one worked. Since my wife likes the f450 we'll keep it. Since we are looking for another camera ritz will give us a gift card. Not the best solution but with the size of the gift card one i can live with.
hobbit91 is offline   Reply With Quote
Old Aug 5, 2005, 9:36 PM   #16
Junior Member
 
Join Date: Aug 2005
Posts: 1
Default

We have taken our f700 into Ritz twice since 1/01/2004 for similar problems. Our photoshad smudge marks on them the 1st time and then, after 2 months use, we had to take it back. The photos weresurrounded with white space the second time. We have had actual use of the camera for a few months, but certainly not1.5 years.

The camera was (and still is) in the shop for repairs and deemed unrepairable. I was offered a F700 used the F450 too and am going to try small claims court if I can't get something better. It isn't a comparable camera, and I'm stuck with the xD cards (256 MB each) and an extra battery, plus the cost of the warranty, so I'll try for the f10 which also isn't comparable but is better I hope, than what I'm reading about the F450. I'd say, given the numerous issues, that the F700 camera is a lemon.

Has anyone had better resolution from Ritz? For example, has Ritz offered anyone a better replacement camera or a partial refund or? Does anyone know of a way to get better resolution from Fuji?


Thanks in advance for any help
goodmart is offline   Reply With Quote
Old Aug 8, 2005, 9:41 AM   #17
Junior Member
 
Join Date: Aug 2005
Posts: 1
Default

Hi all, I'm from Hong Kong. I have the same problem with my F700 too! Mine has been broken down more than a half year ago. At the time the camera went wrong, I only used that for about half a year. Same as rmeglior, I also took good care of it but suddenly one day when I turned it on, only black background with some strips appeared on the LCD. I took it to the Hong Kong Fuji support but they said it costs HK$1700 (about US$220) to get it repaired. I thought it costs too much as I can probably buy a brand new camera with similar functions at about US$250. So I gave up repairing it finally.

At the time I took the camera to the support centre, I thought maybe I haven't taken good enough care of it so it's broken. But actually many of the F700 users suffer with the same problem and it seems it's the problem with this model. I'll try to write a complaint letter to Fuji and see if compensation will be made.

yeelai is offline   Reply With Quote
Old Aug 13, 2005, 3:36 PM   #18
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

I have the same problem with my F700 which is less than a year old.¬* I called Fuji repair in NJ today. When I said f700 the tech immidiately knew what the problem was, they must be getting a lot of these cameras back. I asked about them replacing the cameras with different¬* models as was discussed here but they claimed that they would either repair my camera or send me a "Refurb" of the same model. I guess I'll send it in and see what happens. I have an MX 700 that is 6 years old now and still works as well as the day I got it. This f700 model seems to have been plauged with problems and while it has a great feature set I'd be reluctant to buy another Fuji at this point.
Roger_Jones is offline   Reply With Quote
Old Aug 17, 2005, 7:00 AM   #19
Junior Member
 
Join Date: Aug 2005
Posts: 1
Default

Again, I've the same problem.

Called the Repair centre here in the UK, the tech stated that "Fuji were aware of no problems with the F700" and said that I would have to pay the £129 ($230) standard repair cost.

Anyway after search the web (including this site), I spoke to the UK headoffice & emailed copies of my images along with comments from camera forums - I then get a reply stating "Yes, it appears I do have the common F700 problem and if I send the camera in for repair and they confirm it, they will repair it for free"

So, Fuji are not publishing that the F700 has this common fault (in a way I can understand as this could cost them big bucks!) but lying that no faults exist makes me :X

I'll get my camera repaired for free but I'll never buy a Fuji product again
andywith is offline   Reply With Quote
Old Aug 18, 2005, 8:16 PM   #20
Junior Member
 
Join Date: Aug 2005
Posts: 1
Default

Just want to vent my anger at the F700 too. It had worked perfectly for just over a year, at which time I switched to a Canon S70 and sold the F700 on ebay. After about a week the buyer returned it for a refund. Same problem, the CCD had gone wild. Fuji charged $100 to replace the CCD. Now I have a ebayer who thinks I am a thief. Thanks Fuji.
stagash is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:16 AM.