Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Aug 28, 2006, 4:23 AM   #51
Junior Member
 
Join Date: Aug 2006
Posts: 4
Default

We have now had our camera fixed by Fuji. Although they did fix the CCD free of charge, they also found another fault which the standard £99.90 charge still applied to, so that simply negated the fact that the CCD was being fixed for free! I had no ideaif it was true or not about the extra part or if they were fobbing me off to get their money......I was mad!:?. I had no choice however as I was due to go on holiday in a couple of days and needed my camera back. I also could not argue the point due to no technical knowledge about cameras :P. They fixed it and sent it back super quickly so no grumbles there. Hopefully that is an end to it and I've got my 12 month warranty.
carolineweeks is offline   Reply With Quote
Old Sep 3, 2006, 6:37 PM   #52
Junior Member
 
Join Date: Sep 2006
Posts: 5
Default

Hi I just joined this because of the f700 problems everyone else is getting, but was worried as my serial number is fro the 32A0...series, like yours! I am going to contact fuji tomorrow, anyone have a phone number or contact in the uk?:?
minkeylover is offline   Reply With Quote
Old Sep 3, 2006, 6:43 PM   #53
Junior Member
 
Join Date: Sep 2006
Posts: 5
Default

Hi , i need to send mine back but dont have any contact details? anyone out there help, im in the uk, but would be grateful for an email address to contact fuji?
minkeylover is offline   Reply With Quote
Old Sep 4, 2006, 8:13 AM   #54
Junior Member
 
Join Date: Aug 2006
Posts: 4
Default

Hi! look on their website http://www.fujifilm.co.uk/technical/This will take you to their service and repair section. It will give you all the information you need to know. Alternatively ring their service and repair telephone number which is 0870 084 1314. They are based in Bedford at

Fuji Photo Film (UK) Ltd
Unit 10a, St Martins Business Centre
St Martins Way
Bedford MK42 OLF.

Hope that helps, good luck!


carolineweeks is offline   Reply With Quote
Old Sep 5, 2006, 12:50 PM   #55
Junior Member
 
Join Date: Sep 2006
Posts: 5
Default

fantastic, phoned them and they said they will repair it free!, im so glad i found this fourm, i was gonna try to buy another camera and bin this one!
minkeylover is offline   Reply With Quote
Old Sep 5, 2006, 2:46 PM   #56
Junior Member
 
Join Date: Aug 2006
Posts: 4
Default

Great, I'm pleased for you. I hope that they don't find another fault with the camera like they did with me, thatway they still charge you for the total repair cost. Call me cynical, but I wondered if it were true???
carolineweeks is offline   Reply With Quote
Old Sep 5, 2006, 5:32 PM   #57
Junior Member
 
Join Date: Sep 2006
Posts: 5
Default

guess we wait to find out? I did put on the covering letter that there were no other problems with the camera, in response to what happened to you!, But i have to take there word for it too? Fingers crossed hey?
minkeylover is offline   Reply With Quote
Old Sep 11, 2006, 3:33 PM   #58
Junior Member
 
Join Date: Sep 2006
Posts: 5
Default

wow, i posted it on the tuesday, got a card to say they received it on the thursday and it was returned ,mended ,:|free of charge on the saturday( with a new battery) hows that for service , thanks fuji, and thank you to all you guys who told me about this, saved me a fortune, next round's on me ok?
minkeylover is offline   Reply With Quote
Old Feb 28, 2007, 2:13 PM   #59
Junior Member
 
Join Date: Feb 2007
Posts: 1
Default

This forum is really cool. I had a similar problem with my F700 and was not sure to sell it for £40 (trade in price offered on fuji uk website) or get it repaired for £100. I then came across this forum and saw ppl. having similar problems with f700. Posted the camera to fuji on thursday and got it back today with the CCD replaced free of charge. Thanks Steve and everyone involved in this topic.


ragsm is offline   Reply With Quote
Old Mar 11, 2007, 1:39 PM   #60
Junior Member
 
Join Date: Mar 2007
Posts: 5
Default

Well my f700 is doing the same thing as described I have had the camera for a while as I bought it when it first come out. Its been a good camera up until about a month ago.

Much to my surprise a search on the internet has led me to many forums and I find that ALOT of people have the same problem.

I am just going to pack up the camera and send it to the address I found THANK to this forum. http://www.fujifilmusa.com/JSP/fuji/...quicklink=true

I find that my serial # is 33A30***

So I dont know what will happen will take the time to let you all know. I am going to rufuse to pay for it to get fixed. I have found hundreds of posts, reviews, and fourums of people with the same problem.
sam80277 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:02 AM.