Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old May 20, 2005, 12:38 PM   #11
Junior Member
 
Join Date: May 2005
Posts: 20
Default

Well... just received my second one, and it doesn't have any stuck/hot pixels at all.

One more thing is... I thought the first one took great pictures, but this one blows the first one out of the water. Much, much better exposure, and seems to be less noise too (I didn't even notice any noise with the first camera, until I compared it with the photos taken with this one).

Looks like a keeper.
New2Fuji is offline   Reply With Quote
Old May 23, 2005, 10:31 PM   #12
Junior Member
 
DanmanX's Avatar
 
Join Date: May 2005
Posts: 26
Default

Nice! I took some half-decent night shots of a bridge at night near my house w/ the S5100. I was quite impressed with the ability to control many different manual settings. I might post a pic...but I am an amateur at photography...
DanmanX is offline   Reply With Quote
Old May 24, 2005, 5:00 AM   #13
Baz
Senior Member
 
Baz's Avatar
 
Join Date: Aug 2003
Posts: 219
Default

Hi Mojo, is the 2800 really beyond repair? or can you fix it? Some problems like this are caused in the camera power socket. It has been explained in previous posts. When inserting an AC power plug, contacts there disconnect the battery power. Sometimes these contacts get sloppy. Then the batteries dont get connected.

Just food for thought. I'm sure you will like the later Fuji's you are considering. But the 2800 is no slug. I had that one before getting the Fuji602. Even thou the 2800 is fully auto, Looking back at the 2800 pics,they compare more than favourably with the 602 ones.
Baz is offline   Reply With Quote
Old May 24, 2005, 5:55 AM   #14
Junior Member
 
Join Date: May 2005
Posts: 6
Default

I have read some of the previous posts regarding what you have described. But I do not have the AC adapter for the 2800. How can I tell if the contacts are "loose", without plugging in an adapter?

BTW, the 5100 finally arrived late yesterday via UPS. Still playing with my new toy. I'll post some sample pics later.
mojo_jojo is offline   Reply With Quote
Old May 26, 2005, 6:30 PM   #15
Junior Member
 
Join Date: May 2005
Posts: 6
Default

Pic of my new granddaughter. The room was completly dark at the time.

Attached Images
 
mojo_jojo is offline   Reply With Quote
Old Jun 2, 2005, 9:30 PM   #16
Senior Member
 
sincerecowboy's Avatar
 
Join Date: May 2005
Posts: 116
Default

well mojo i also ordered a new fugi S5100. I read a lot of reviews on it and the only cons i read were the expensive memory cards and no image stabilization, but seems like everyone that has this camera said that they take good shots at full zoom without it and saw some of the pics taken so i think ill be pretty happy with the camera when i get it hopefully in a few days ha ha i ordered it through dell so that i also have a 30 day moneyback satisfaction guarantee from dell. I order everything i can through dell somemtimes its cheaper and sometimes i pay a little more but well worth the service i get. When you get some pics posted would love to see them
sincerecowboy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:01 PM.