Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jul 26, 2005, 6:11 PM   #11
Senior Member
 
Carskick's Avatar
 
Join Date: May 2005
Posts: 276
Default

Well, my Fuji came today, finally. They did a great job, it's all better. But it took them about 5 weeks!! :shock:
They need to speed up their service. Otherwise, good job. As long as it stays trouble free, I'll be satisfied. I just hope it is sealed to keep the inner lens and ccd clean. I was so happy to get my camera back. This new camera has become a good friend, and I'd hate to be without it for a long period of time again. My old Fuji 2650 seemed really bad after using me e550 for so long (about 2 months when I sent it back). It is MUCH slower, not nearly as powerful, and almost embarassing. The only this is I am scared to take my camera where it is dirty, even through I think the ccd was dirty when I received it, it just took me a little while to notice it, as it only showed up in certain occassions. So now I will be back to partisipating in photo events, and poasting pics, and improving my skill to best utilize my camera.
Carskick is offline   Reply With Quote
Old Jul 27, 2005, 6:15 AM   #12
Senior Member
 
Goofas's Avatar
 
Join Date: Jul 2003
Posts: 734
Default

Glad to hear all is good again.
Goofas is offline   Reply With Quote
Old Jul 27, 2005, 6:06 PM   #13
Senior Member
 
Carskick's Avatar
 
Join Date: May 2005
Posts: 276
Default

Arg!

Well, after some more photo fun, I noticed it is still there in blue sky, but not as bad. I guess this is something I'll just have to live with. After I sent off my camera for this, I realized many cameras have these after looking at some camera review. Some of steve's test have small dots. I guess it's something some of us have to live with...At least it's better. It is much less noticable, and I will cease to worry about it, because I rarely take pictures where it is noticable now. I just think for having 5 weeks, Fuji could have fixed it. I give Fuji a 2.5/5 for service. It was slow, and cost me $7 including insurance to ship (As Fuji requested), They did get it back to me in a good fasion, and improved the situation.

Actually, it's really only there in blue sky, or when zoomed in for some reason. Strange. Oh well. Still a great camera, just a slight artifact now.
Carskick is offline   Reply With Quote
Old Jul 30, 2005, 1:28 PM   #14
Senior Member
 
Carskick's Avatar
 
Join Date: May 2005
Posts: 276
Default

Well, after further use, I realized the spot is just as bad as before. I wrote Fuji and told them what I thought. Fuji really needs some revisions in service and support, as well as quality control at the factory. I use to really like Fuji. But that is changing, and it is unlikely that my next camera will be a Fuji.
Carskick is offline   Reply With Quote
Old Nov 14, 2005, 5:54 PM   #15
Senior Member
 
Carskick's Avatar
 
Join Date: May 2005
Posts: 276
Default

It has been a while, but I am back on the camera scene.

After a little more bickering with Fuji, I am satisfied with their service. I finally talked to someone higher in the Fuji hierarchy, and they sent me a prepaid Fed-ex sticer. I received a call 1 week after sending the package saying they were going to replace the camera, but they were out of e550s at the time, and offered me a new retail F10 with a complele 1 year warranty. At first I was not entirely excited because the F10 was different in many aspects where I wish it wasn't. However, I was happy Fuji was willing to give me a more expensive new camera at no extra charge, and not make me wait, give me a refurb, or send me an OEM version. Hopefully their overall service is improving, as they were much more responsive this time.

After they told me they were going to send out the F10, they shipped it overnight on Tuesday, and I got it on Thursday, so not bad. I was excited about my new toy, and since I studdied up on the F10 when it first came out, I knew what it could and could not do.

What I like about it compared to the e550:
-Its excellent ISO capabilities. It has less noise at ISO800 than the e550 did at 400, and ISO1600 is usable for extreme situations
-Its smaller size makes it more pocketable
-Sturdier construction, more metal
-No spots or problems occuring one my pictures!
-Quickness.
-Fine 6MP mode
-15 sec exposure capability
-Larger Screen
-Pictures very similar in quality, though much less noisy at high ISO, possibly a little grainery at low ISO
-Controls not so easy to change on accident
-Powerful flash
-Auto exposure more accurate
-USB cover attatched

What I do not like about it compared to the e550
-36-108mm comparable lens range does not compare to the 32-128mm
-Lack of full manual control of apeture and shutter, not even priority ability
-Although Li-Ion battery has better life, I prefer the AA solution
-More red eye due to lower flash, and flash stranegthnot adjustable
-Auto WB not quite as good, but still has great custom mode, thank God
-Less comfotable to hold
-Terminal needed to charge the camera, a total of 3 seperate wire-sets
-No optical viewfinder
-Larger screen has 3/4 as many pixels 115k vs 154k
-Seems less professional, due mainly to smaller size and lack of true manual features

Otherwise, the cameras are very similar, and I like them both. The low noise ISO settings are what really sell this camera. I can get some great no flash shots at ISO400 and have practically no grain. ISO800 begins to sacrifice quality, but even 5x7 prints should not reveal the noise, and 8x10 wil still likely be acceptable.

And just FYI, there is not much point in using the fine quality setting over ISO400 IME, as the JPEG noise is inconsequential due to sensor noise. Although the fine mode is available, as with the e550, the normal 6MP mode shows very few JPEG artifacts, so I find it is worth using to double picture capacity. I will only use the fine setting when I plan on really blowing it up. I will be back on the forum now with my F10, posting my pictures, the camera chaos prevented my presence here, but it's over now.
Carskick is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:43 AM.