Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Fujifilm (https://forums.steves-digicams.com/fujifilm-22/)
-   -   S9500 is now in OZ (https://forums.steves-digicams.com/fujifilm/65523-s9500-now-oz.html)

[email protected] Sep 2, 2005 7:23 AM

Yo folks,
For any aussie that are Interested, www.centre.net.au has the S9500 in stock at app oz$842 +GST I've bought a lot of stuff from them before, so I can vouch they're ok.
They also have true International warranties (often replacement), which is handy.
If I can get the service manual and spares from Fuji, I may just grab one to see if they finally fixed issues with past models (S4900-S7000).
JKirk


gaul Sep 2, 2005 4:49 PM

Thanks, it's actually a good price as I would not have to pay the VAT and if I can avoid the UK customs :evil:



nickphoto123 Sep 2, 2005 5:35 PM

Good luck with your new S9500 camera.

Can you set it on forced flash mode and take a couple of shots to see how long the internal flash re-cycles and before permittingyou to take your next shot?

I read that it took 7 seconds to re-cycle. Is this accurate? Please report your findings.

Thank you, Nicholas



s9500 Sep 19, 2005 11:25 AM

It takes nowhere near that amount of time. I took a couple of forced flash photos at 9MP Fine (in auto mode) just to check for you. It took approximately 2 seconds for the camera to be ready for the next forced flash photo.:cool:

What could have taken close to 7 seconds is if the shots were taken in RAW format.

This is accurate if using an XD card, but has nothing to do with flash.

The speed of an XD card is 3MB/sec and so a RAW photo which would be close to 19MB would then take close to 7 seconds to record to media. I have yet to test if a faster CF card (say 80x - 12MB/sec) would lower this time. Will report here when I get one soon.

gaul Sep 19, 2005 12:18 PM

Did you experience this "blank screen phenomenon" between 2 pictures (not sure if occured only with flash) reported by some early users?

Thanks

s9500 Sep 19, 2005 1:27 PM

No blank screen. By the way there is a setting that gives you a choice whether to display the shot you just took for 1.5 secs, 3 secs or none. Not sure if this is what you mean.


All times are GMT -5. The time now is 8:11 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 RC 2