Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Sep 15, 2005, 4:28 PM   #1
Junior Member
 
Join Date: Sep 2005
Posts: 7
Default

hi just had my new finepix s9500 and love it but after 20 or so photos taken the batteries that came with it were flat,so ive put my rechargeables in and the same thing has happend,anyone else had this problem.
swansong is offline   Reply With Quote
Sponsored Links
Old Sep 15, 2005, 6:15 PM   #2
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

That's not right - Fuji claims 140 pics with alkalines, so you'd probably have to expect at least twice that amount with NiMH's. Were the rechargeables fully charged?

the Hun

rinniethehun is offline   Reply With Quote
Old Sep 15, 2005, 9:30 PM   #3
Senior Member
 
CCWKen's Avatar
 
Join Date: Mar 2005
Posts: 221
Default

Ah, you make me sick.:roll: I can't even get a S9000 yet and you're complaining about Chinese batteries? :-)

As the Hun says, make sure you NiMH's are fully charged. Are you using the flash too? Continuous focus? These draw heavily on the batteries.
CCWKen is offline   Reply With Quote
Old Sep 15, 2005, 11:15 PM   #4
Senior Member
 
shadowlies's Avatar
 
Join Date: Sep 2005
Posts: 251
Default

I had the same problem with the batteries straight out of the box but since I have put in the rechargables (brand new, Ni-MH 2500mAh) I am up to 200 pics and still going.

I have been putting a strain on the batteries too. Auto focus (single & continous), flash, downloading pics through the camera (without external power source) etc.

I would check the mAh of your recahrgeable batteries and if you have had them for a while they may be on their way out.

Just my 2 cents.

PS Are you using a CF card or just the xD card? I have heard tell that CF cards can also be a drain on batteries. I do not know how much substance there is to that theory, hopefully someone can enlighten me.
shadowlies is offline   Reply With Quote
Old Sep 16, 2005, 1:32 AM   #5
Senior Member
 
SteveDak's Avatar
 
Join Date: Sep 2005
Posts: 1,471
Default

Had same problem with my 5100 when I first got it - on decent 2500 rechargeables it goes for ever.

One additional point to all the above - we tend to forget how much we "fiddle" around with our new prize possession when we first get it ,without actually taking a picture! Power on, power off,testing every thing out and initially probably only having 10-20 shots on the card & we've spent a lot of time reviewing them. The alkalines don't stand a chance. Just my thoughts on the subject.
SteveDak is offline   Reply With Quote
Old Sep 16, 2005, 3:09 AM   #6
Junior Member
 
Join Date: Sep 2005
Posts: 10
Default

Was also very dissapointed when I put in the supplied AA batteries.... Lasted about 15mins!!!

I went and got myself a set of 2500mah rechargables.... Charged them up 2 days ago when I got them and they are still running .


Even a regular set of duracell lasted me much longer than the supplied batteries did.


Its unfair to say this is a prob with the S9X00 as most high powered compact devices would behave in the same way with poor batteries.


What rating are your rechargables? Are they brand new or are they quite old?



Sin.






Sintax is offline   Reply With Quote
Old Sep 16, 2005, 12:37 PM   #7
Junior Member
 
Join Date: Sep 2005
Posts: 7
Default

thanks guys for the info.
swansong is offline   Reply With Quote
Old Sep 16, 2005, 12:45 PM   #8
Junior Member
 
Join Date: Sep 2005
Posts: 7
Default

Sintax,ive had my rechargables about 2 years now,i m thinking of getting some 2500 ni mh.
swansong is offline   Reply With Quote
Old Sep 16, 2005, 7:48 PM   #9
Junior Member
 
Join Date: Sep 2005
Posts: 10
Default

I think the 2500MaH are a must

If you are from the UK, try looking in Argos. I got mine from there with a fast charger for a real cheap price!


I have seen some VERY cheap 2500's on ebay but I have never heard of the company that makes them before.

I always buy batteries from company with good rep as I used to have a remote control helicopter and the dodgy battery exploded whilst on charge and destroyed my kitchen!!!


Have fun snapping!

Sin
Sintax is offline   Reply With Quote
Old Sep 17, 2005, 1:47 PM   #10
Junior Member
 
Join Date: Sep 2005
Posts: 7
Default

hi sintax i am from the uk,il have a look in the argos book,ive been out today at a local canal boat show and have taken 170 photos,so all is well with the camerathanks for the info.
swansong is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:40 PM.