Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Feb 12, 2006, 5:28 AM   #11
Junior Member
 
Join Date: Feb 2006
Posts: 2
Default

My Fuji F700 ccd (Serial No :33L *****) has failed it started displaying a green & pink fuzzy image on its lcd viewer but its now gone compleatly black with a few white spots, I`v sent it back to fuji Uk and last week they have sent me a bill for £129.50 to repair it. I phoned up Fuji Uk to query this and told them that this is a known issue with this model of camera & the told me that if it is a CCD fault then they will repair this for free :!:& they will let me know within 48 Hours, More than 3 days have past since i have spoken to them and I have yet to hear from them. I supose I will have to phone them on monday when their phone line are open again & I think they will try to fob me off!! If they do I will never buy a Fuji camera again!!!:sad::sad::sad:
ian.cooper277 is offline   Reply With Quote
Old Feb 14, 2006, 5:39 AM   #12
Junior Member
 
Join Date: Feb 2006
Posts: 2
Default

ian.cooper277 wrote:
Quote:
My Fuji F700 ccd (Serial No :33L *****) has failed it started displaying a green & pink fuzzy image on its lcd viewer but its now gone compleatly black with a few white spots, I`v sent it back to fuji Uk and last week they have sent me a bill for £129.50 to repair it. I phoned up Fuji Uk to query this and told them that this is a known issue with this model of camera & the told me that if it is a CCD fault then they will repair this for free :!:& they will let me know within 48 Hours, More than 3 days have past since i have spoken to them and I have yet to hear from them. I supose I will have to phone them on monday when their phone line are open again & I think they will try to fob me off!! If they do I will never buy a Fuji camera again!!!:sad::sad::sad:
Got my camera back from Fuji today and they have repaired it for free, its just a pity in the Uk you have to put up a bit of fuss to get this done!!
ian.cooper277 is offline   Reply With Quote
Old Apr 28, 2006, 11:41 AM   #13
Junior Member
 
Join Date: Apr 2006
Posts: 1
Default

FUJI F700, i got a f700 in august 2004 serial number 34L*** , anyway my warranty run out august 2005 and in about october 2005 i went to use my camera and all i got was a purple/green LCD, grrr, as it was out of the 12month warranty i thought it was a waste of time to try and contact them, BUT i recently did a search on google and ended up here, to find out its a common problem with the F700, so i called FUJI last Thursday 20th April 2006 and the lady to me to send it to their repair centre in bedford, GOT MY CAMERA BACK YESTERDAY 27 APRIL 2006 REPAIRED AN NO CHARGE! WELL DONE FUJI, YIPEEE:blah:
london_guy2006 is offline   Reply With Quote
Old Jul 4, 2006, 2:04 AM   #14
Junior Member
 
Join Date: Jul 2006
Posts: 1
Default

I'm so glad I found this forum! I purchased the F700 in Seattletwo and a half years ago and it worked great. Now suddenly although the battery works fine and I can visualize all the settings and change them in the LCD monitor, the image is black and it takes nothing but blank pictures, although the flash is working. The serial number begins with 33A1****. I'm about to take a trip to China so I was so bummed my camera is broken...but I'm going to send it in to Edison and see what they say.

I'm so glad this is a known defect so at least I can mention it because it sounds like they snow you otherwise. I'm not sure I have the same problem as everyone else but it sure sounds like it...my camera was just sitting around unused for a while and then suddenly it wasn't working anymore.

I'll write back and let you all know what happens.

Hopefully this will be me --->:|again soon.

--J
jujube is offline   Reply With Quote
Old Aug 5, 2006, 5:34 PM   #15
Junior Member
 
Join Date: Aug 2005
Posts: 4
Default

I have a similar problem with my F700 except the photos come outcompletely white or, less frequently, with a large white overexposed area in the middle. Just prior to this problem the photos startedappearingwithwhite boarder around them.

I've had the camera over two years. This problem started6 weeks ago. I have no idea of what caused it. Everything else functions normallly. Also my serial number is not on the list. It's 34A00... Any help would be greatly appreciated.:?

PS the last time I used this forum my blacksmear spot problem was miraculously cured by one of you guys.

Attached Images
 
jbeckplano is offline   Reply With Quote
Old Aug 8, 2006, 9:41 AM   #16
Junior Member
 
Join Date: May 2006
Posts: 1
Default



I had the same problem, pictures totally whiteand white ring with purple edge. I sent my camera to Fujifilm and they repaired at no cost. It works fine now. Fuji replaced the ccd (?). I had my camera one year and 11 months before sending it back.
kismat is offline   Reply With Quote
Old Aug 21, 2006, 2:25 PM   #17
Junior Member
 
Join Date: Sep 2003
Posts: 22
Default

This sounds like the old "bad CCD from Sony"situation from the last couple years, the same problem that plagued Konica-Minolta cameras of the Dimage lineup and must have cost Minolta an arm and a leg in fixes and shipping charges.

Can anyone clarify who makes the CCD's used in Fuji digital cameras?
Robert Johnston is offline   Reply With Quote
Old Aug 23, 2006, 9:56 PM   #18
Junior Member
 
Join Date: Aug 2006
Posts: 2
Default

I had my F700 fail for the sensora little over a year ago. The unit was dropped off at the Edison, NJ facility. Shortly thereafter I recieved a "replacement" unit that while functional, was cosmetically FAR from perfect. As it was at that point a discontinued model, I was at least happy to get a like replacement. I really like the camera. About a week ago, I was in a position where I absolutely needed the camera to take some unique shots. To my surpise (and horror), the replacement unit (sent by Fuji) was now exhibiting the failed CCD! A perhaps once in a lifetime event could not be captured. This SECOND defective unit was returned to Fuji to be again covered under the "CCD Advisory". I do hope that I again get an F700 returned to me - and one that is actually free from the cursed run of SONY CCDs. Unfortunately, I will be quite hard pressed to purchase another Fuji camera. That the replacement unit that just failed had a known "bad serial number" makes me wonder if Fuji really cares about it's customers. I can accept a unit failing once. And I can accept that the replacement had dents and scratches. Butto have been sent a replacement with a "bad" serial number only to experience the same failure yet again destroys my confidence in Fuji as a brand. Let's see how they handle this...
wlg4 is offline   Reply With Quote
Old Sep 2, 2006, 11:03 AM   #19
Junior Member
 
Join Date: Sep 2006
Posts: 1
Default

Hi. My f700 has just started to go wrong. First it was "ghosting" round the edge of images, now its totaldistortion. I'm in the UK and will be contacting /fuji on Monday morning. Incidentally my local Jessops store wanted £178 (!!!) just to check my camera over and suggested I bought a new model. Surelyas the UK's biggest camera retailer, they must of known about thef700's problems? They didn't bother to mention it to me. If I do get a new camera 1. it won't be a fuji 2. it won't be from Jessops.
stumpysdad is offline   Reply With Quote
Old Sep 4, 2006, 10:18 AM   #20
Junior Member
 
Join Date: Sep 2006
Posts: 1
Default

Funny you should mention Jessops.

My 700 developed this problem over the weekend, much to my dismay. I took it in to Jessops, who offered to send it back to Fuji for me for £40. The assistant manager of the shop suggested it could cost as much as £120 to fix, and btw, there's a special offer on the <someothermodel> for just £200 this week.


Came back, spent a while researching different cameras, and finally twigged on the great idea to search for "fuji f700 replacement" to find what model was the suggested upgrade. Imagine my surprise to find this thread. I cannot believe that Jessops are unaware of this problem.

Anyway, a quick phone call to Fuji and the operator volunteered that there exists a problem with some f700s, and I can send it back for free repair/replacement if that's what's wrong. Will be posting it tomorrow, at a lot less than £40.

lycralout is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:11 AM.