Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Feb 8, 2003, 7:04 PM   #1
Junior Member
 
Join Date: Feb 2003
Posts: 2
Default Fuji S602 NiMH batteries not working.

Hello all,

Can I please get some recommendations on NiMH batteries for this camera that will work? I purchased 2 sets of DigiPower AA from CompUSA and charged over night. Neither would work with the camera. Regular (alkaline) batteries worked with it fine. I noticed that the batteries were 1.2 volt instead of the typically 1.5 volt for AA. I returned them and noticed all the NiMH batteries of other brands were 1.2 volt instead of 1.5 volt. Is this a problem with this camera? If someone has good luck with a particular kind I'd appreciate hearing from you. My one set of alkalines won't last long. :-)

Thanks for your time.

-- Jeff
JHester is offline   Reply With Quote
Sponsored Links
Old Feb 8, 2003, 7:21 PM   #2
Junior Member
 
Join Date: Dec 2002
Posts: 24
Default

I have many different sets of NMI batteries at all capacities. They all work in three digital cameras. The difference in capacity just means how long they will last.

Are you sure that they were properly charged? While it seems silly to ask, did you correctly place them in the camera? I have reversed batteries and it took a couple of tries to get it right. The markings on the cameras for battery placement aren't necessarily the clearest.

If the camera works with AA throwaways then it should work with rechargables.
Ron Kaplansky is offline   Reply With Quote
Old Feb 9, 2003, 4:23 PM   #3
Senior Member
 
Join Date: Aug 2002
Posts: 2,162
Default

I've actually marked the battery cover edge on my 602 with a white marker, so I can get the batts in the right way round in a hurry and at night! The small difference in voltage doesn't seem to make any difference with my batts. Perhaps there's a step up regulator following the battery pack, also used for the dc in?
voxmagna is offline   Reply With Quote
Old Feb 9, 2003, 8:50 PM   #4
Junior Member
 
Join Date: Nov 2002
Posts: 8
Default

Have you checked if your charger is in fact charging the batteries. Insert the batteries in a flash light if you do not have a volt meter or any other means of checking the battery output
Good Luck..Rafael
Rafael is offline   Reply With Quote
Old Feb 10, 2003, 10:06 PM   #5
Junior Member
 
Join Date: Feb 2003
Posts: 2
Default

I tried a different charger and different kind of batteries and they worked great. I used a Rayovac charger and Energizer 1850 NiMH batteries and the camera works. I guess the Digipower batteries and chargers are just not a good brand. The Digipower supposingly charged the batteries in 4 hours and the Rayovac took overnight to charge. The Digipower batteries did successfully light a flashlight though.

I look forward to a lot of good use with the 602. Now, I'll just have to get another set of NiMH batteries to have on hand.

Thanks for everyone's help.

-- Jeff
JHester is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:34 PM.