Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Dec 12, 2005, 3:27 AM   #21
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear Edster77!

We will be very pleased, if you can read your camera instruction, very well & comprehend what is composed there, as really I can't understand how is possible that your two newer cameras came defectives. Seems/appears; me that you don't cognize how to use it...!

Sorry; but mine works so lovely...that I suggested to more amicables here in Israel...all of them are very happy using their S9500!

All the best!

Alex007:|
Alex 007 is offline   Reply With Quote
Old Dec 12, 2005, 5:53 AM   #22
Senior Member
 
In search of Syd's Avatar
 
Join Date: Nov 2005
Posts: 1,657
Default

S9500 - serial number - 53Q00386 Faulty - blown pixels appearing on the EVF, LCD and in all images.
In search of Syd is offline   Reply With Quote
Old Dec 12, 2005, 6:22 AM   #23
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Hello dear Syd!

Sorry, with my S9500 such fault don't appear! Mine still 100% perfectly!

Drop a mail to UK after sales/customer or client services, I'm 100% sure that they will help you much better that me.

Inform me what happen...please Syd.

Geetings.

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Dec 12, 2005, 6:35 AM   #24
Senior Member
 
In search of Syd's Avatar
 
Join Date: Nov 2005
Posts: 1,657
Default

Hi 007.

Actually it is those of you like yourself who are/havenot experienced any problems and like their cameras that restore my faith in the model. Right now my faith needs restoring. I am really pleased yours is working fine and others too. I really want this camera to be right and work for me.
In search of Syd is offline   Reply With Quote
Old Dec 12, 2005, 8:09 AM   #25
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear Syd!

Be 100% sure, that never I will offend/appal any person, if...this happen, sorry!

My sole advice is to send to the official Fuji repair station, near where you live, so when you will receive it back...all will be fine.

All my best wishes,

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Dec 12, 2005, 9:57 AM   #26
Member
 
Join Date: Aug 2005
Posts: 67
Default

Alex 007 wrote:
Quote:
We will be very pleased, if you can read your camera instruction, very well & comprehend what is composed there, as really I can't understand how is possible that your two newer cameras came defectives. Seems/appears; me that you don't cognize how to use it...!

Sorry; but mine works so lovely...that I suggested to more amicables here in Israel...all of them are very happy using their S9500!
Dear Alex.

Many photogs are very pleased and happy with their s9000. We're glad you're satisfied with yours.

However, other (experienced) users are having *real* problems with their s9000. Please don't belittle their problems. Don't assume these guys are too stupid to read or understand a manual. Please let them express their problems without immediately trying to convince them it's all their own fault.

Your attitude "mine works soooo lovely so yours just can't be defective - RTFM!" isn't helpful.

nymano.
nymano is offline   Reply With Quote
Old Dec 12, 2005, 10:36 AM   #27
Senior Member
 
SteveDak's Avatar
 
Join Date: Sep 2005
Posts: 1,471
Default

Well said Nymano, I've noticed an unfortunate trend developing recently whereby there is a subtle (and not so subtle sometimes)inference that those whoexpress aconcern about the camera are somehow either misguided, deluded or technically inept.Time may yet show that these concerns were justified and that the camerawas neverintended to be ascomplex as someare makingit out to be.






SteveDak is offline   Reply With Quote
Old Dec 12, 2005, 11:03 AM   #28
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear Nymano & SteveDak!

OK...you two are 100% right, so many S9000/9500 leave the factory defective?

It's really for me something that can't be comprehend, with "today's" automatising, or Fuji...produce so many S9000/9500 that "Quality" final control or do not exist, or exist "Only" among a few of them...how you two can explain such quantity of defective cameras?

Greetings.

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Dec 12, 2005, 11:21 AM   #29
Senior Member
 
SteveDak's Avatar
 
Join Date: Sep 2005
Posts: 1,471
Default

Ilive in the eternal hope that Fujiwill one day answer this deep & ponderable question and thereby make sense of whysome cameras have apparently been so readily replaced.
SteveDak is offline   Reply With Quote
Old Dec 12, 2005, 3:38 PM   #30
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear SteveDak!

To the folk from Fuji factory, who email me the new 1.02 firmware, I ask him the same question...till yet...NO response!

My feelings told me that never, I will receive any response on such "Faulty" cameras issue.

Cheers,

Alex 007:|
Alex 007 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:30 PM.