Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jan 28, 2007, 8:37 AM   #21
Junior Member
 
Join Date: Jan 2007
Posts: 13
Default










Dear Dean,


Thank you for contacting Fujifilm UK.

The command dialing failing on the S9500 is a known issue. The repair entails a new top cover, which features a redesign to the contacts of the command dial.

For future reference you are welcome to bring a camera in for repair, but please note we do not operate an 'on the spot' repair service. Our address is as follows:

Fujifilm Camera Service Unit 13 St Martins Business Centre Bedford MK42 0LF



Sincerely, Fujifilm


[line]

Original Message:

I have sent my fuji s9500 back to my retailer for repair as the command dial has broken, I have since gone online and realised this has been a massive and very well known problem for some time now. I would like to know if the replacement parts are made of better components to prevent a repeat of this problem, I am worried as I have got reports of some customers having to send them back more than once as the same problem is re-occuring. I also am annoyed at the postage cost to my retailer when I live in Bedford 5 minutes walk away! .

The letter andreply in full.
deanbed is offline   Reply With Quote
Old Feb 26, 2007, 2:08 AM   #22
Junior Member
 
Join Date: Jan 2007
Posts: 6
Default

my amera came back from repair ...........



first they glued the dial on... I was very angry and demanded a new cover eventually they replaced it on the spot..



i saw the new piece it has a metal pin........
aymen1 is offline   Reply With Quote
Old Mar 3, 2007, 7:18 PM   #23
Junior Member
 
Join Date: Jan 2007
Posts: 13
Default

Glad to hear they replaced yours with the improved part.

Six weeks later I am still without my camera from repair, why does it take so long?.

Its about time there was some law on how longthey are allowed to havean item in for repair, if it went just once more that would be 3 months out of the 1 year warranty without the goods, I reckon they should divide the cost of the goods by 52 weeks and every week its in for repair you get the equivelent in money back, it might encourage the manufactures to test their goods more thoroughly before palming them off on the public.

If I soundpissed off I am, sorry but its like my arms been cut off.
deanbed is offline   Reply With Quote
Old Mar 4, 2007, 2:52 AM   #24
Junior Member
 
Join Date: Jan 2007
Posts: 6
Default

it actually takes 5 minutes to replace the cover i dont know what is wrong wih them...... never buy a Fuji that is my advice..............



iam also disapointed with them.



aymen1 is offline   Reply With Quote
Old Mar 20, 2007, 12:26 PM   #25
Junior Member
 
Join Date: Jan 2007
Posts: 13
Default

I am now completely pissed off.

My Fuji S9500 came back with a new command dial after being away for 8 weeks.

the next day I took it out it has gone again, despite them telling me it was an improved part.

I will get this sorted, but no more Fuji's for me!
deanbed is offline   Reply With Quote
Old May 6, 2007, 5:08 AM   #26
Junior Member
 
Join Date: May 2007
Posts: 1
Default

I noticed your post after My S9500 developed the same problem with the command dial. I'v had it since Nov 05, but not used it so much until recently.. now its broken. Fuji want £99 to fix it. Is there any way you can send me a copy of the written admission of a fault you managed to get from the Fuji technician. It would help me greatly to pursue a claim under the sale of goods act. Any help would be appreciated

Thanks


Springer is offline   Reply With Quote
Old Jan 31, 2008, 2:51 AM   #27
Junior Member
 
Join Date: Jan 2008
Posts: 3
Default

deanbed wrote:
Quote:








Dear Dean,


Thank you for contacting Fujifilm UK.

The command dialing failing on the S9500 is a known issue. The repair entails a new top cover, which features a redesign to the contacts of the command dial.

For future reference you are welcome to bring a camera in for repair, but please note we do not operate an 'on the spot' repair service. Our address is as follows:

Fujifilm Camera Service Unit 13 St Martins Business Centre Bedford MK42 0LF



Sincerely, Fujifilm


[line]

Original Message:

I have sent my fuji s9500 back to my retailer for repair as the command dial has broken, I have since gone online and realised this has been a massive and very well known problem for some time now. I would like to know if the replacement parts are made of better components to prevent a repeat of this problem, I am worried as I have got reports of some customers having to send them back more than once as the same problem is re-occuring. I also am annoyed at the postage cost to my retailer when I live in Bedford 5 minutes walk away! .

The letter andreply in full.
I was told by the Fujifilm Ireland that the "comand dial" is not considered a known issue they went further and said others had mentioned this problem being an issue on the net etc. They said that they had contacted Fujifilm UK (they do all the Irish repairs) and were told by them that it wasn't an issue! So now I have to fork out €166.32 to have it repaired.

Is there anyone at Fujifilm UK that I could contact in regard to fixing this camera?

All help appreciated,

Rob
jaqian is offline   Reply With Quote
Old Jun 21, 2009, 2:11 PM   #28
Junior Member
 
Join Date: Jun 2009
Posts: 2
Default comand dial

if i replace the whole Top cover mode dial assembly with a new one will that fix my broken comand dial problem
techn9nen9ne is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:59 PM.