Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Apr 25, 2006, 2:42 PM   #1
awp
Junior Member
 
Join Date: Apr 2006
Posts: 6
Default

Just purchased a Fuji F10 (open box, clearanced for $95!). After reading more about the camera, I'm excited and can't wait to play around with it.

However, I noticed that when I switched from Auto to Manual mode, there were a lot of clicking noises. I never heard anything of the sort on my former Canon A40 so I was a little disturbed. It stops after about 5-10 seconds. Guess the camera is adjusting itself to whatever had been set in the manual mode previously. But it kind of freaks me out. Is this normal? Or did I get a lemon?
awp is offline   Reply With Quote
Sponsored Links
Old Apr 25, 2006, 5:49 PM   #2
awp
Junior Member
 
Join Date: Apr 2006
Posts: 6
Default

Well, kind of strange to say this, but I compared the output from my new Fuji F10 to my Canon A40, and another clearanced camera, a Kodak Z700....and the loser was the F10. I was shocked. I took several pictures in different lighting and in all three cases the F10's quality was worse than the other two (even though the A40 is only a 2MP, three year-old camera). I actually think I'm going to go with the Z700 and return the F10.

The Canon easily had the best color, but the Z700 had the most crisp images. The F10 had noticable noise in the low light photo I took which I was expecting it to ace that one.

Who knows maybeI got a bad one as an open box, but I can't afford a new one for $200+.
awp is offline   Reply With Quote
Old Sep 19, 2007, 4:14 PM   #3
Junior Member
 
Join Date: Aug 2007
Posts: 2
Default

I think you found out why it sold as "open box". Return it.

Bobz086 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:12 AM.