Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   General Discussion (https://forums.steves-digicams.com/general-discussion-11/)
-   -   Olympus battery charger (long message) (https://forums.steves-digicams.com/general-discussion-11/olympus-battery-charger-long-message-21315/)

pavaros Mar 1, 2004 12:42 PM

Olympus battery charger (long message)
 
Hi everyone!

my olympus C-750 came with the standard Olympus BU-300 battery charger and 4 olympus 1.2v-1700 mAh batteries. The charging time for the batteries is around 9 1/2 hours..(charger's output 1.2v-240 mAh).

The included batteries served me fine for the first weeks but due to frequent camera use i ve got another pack of 4 hahnel 1.25v-2350 mAh, for extra power. I ve started charging the new batteries on the olympus charger but i dont know if i was supposed to do that or if my new batteries are getting charged properly. When i recharge the Olympus batteries the charger cuts off the power and the charge light goes off after 9-10 hours, meaning that the batteries are fully charged.

However, when i recharge the hahnel batteries which have 40% more capacity the charger still switches off after 9-10 hours....with 240mah output it would need 14 hours to recharge them normally..meaning that they are not fully recharged?? what i then do is unplug the charger from the mains and replug it and the charging light switces on and i continue to charge for an extra 4 hours (9-1o hours + 4= 14).

What i dont understand is that if the charger shuts down when it recognises the 1700mah(9 hours of charging) why when i unplug and replug it continues to show that it charges??and do the hahnel 2350 batteries get fully charged or i am doing something wrong and i ll burn both batteries ans charger???

slickShooter Mar 1, 2004 4:08 PM

I too own the Oly c-750 with the supplied charger and batteries.I also bought a second set of batteries (Panasonic 1950mah) at purchase.
I have charged the 1950's in the charger with no harm to the charger or batteries so far.i have probably charged maybe 25 times or so.
If what you say about the charger shutting down after 9-10 hours is fact then I suppose having 1950's is useless.
All I know is no harm so far and im happy........search around this topic has been covered.......try the Oly forum.
Cheers,
Ps please share any pictures you have.....I'd love to see em

pavaros Mar 3, 2004 1:01 PM

thanks for your response!
i would love to share my pictures but i still havent found the right site to upload them....any suggestions?

slickShooter Mar 3, 2004 2:31 PM

I use FOTOPIC.NET to host my pics.......its free,easy to use and lots of storage for my needs.

Check them out below

pavaros Mar 3, 2004 2:45 PM

thanks!! i ve just done the same, here is my first pic!


All times are GMT -5. The time now is 1:13 PM.