Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   General Discussion (https://forums.steves-digicams.com/general-discussion-11/)
-   -   problems with my Olympus C750UZ (https://forums.steves-digicams.com/general-discussion-11/problems-my-olympus-c750uz-26144/)

albireox May 25, 2004 11:41 AM

Well, I bought my Olympus C750UZ a few days ago. Everything seems fine, I'm happy with the picture quality so far. But I notice somethig pretty strange. The objective of the camera shakes a little, just like it wasn't fixed right. Is that a problem with my camera or is something common with any ultra zoom camera.
Thank you!

Puck M May 25, 2004 12:17 PM

albireox wrote:
Quote:

Well, I bought my Olympus C750UZ a few days ago. Everything seems fine, I'm happy with the picture quality so far. But I notice somethig pretty strange. The objective of the camera shakes a little, just like it wasn't fixed right. Is that a problem with my camera or is something common with any ultra zoom camera.
Thank you!
style="BACKGROUND-COLOR: #666666"http://www.stevesforums.com/forums/v...;highlight=750

Take a look at the above thread.There may be others if you do a search in the Olympus forum.



Mikefellh May 25, 2004 5:39 PM

There are many messages on this subject in the Olympus forum...the lens wiggle is perfectly NORMAL and nothing is wrong; the lens is designed to "float" in the assembly.

Most C-7x0 users will recommend using a filter adapter tube with a UV filter on the camera at all times to not only protect the lens from dust and scratches, but from also being bumped out of alignment.

- Check out the Oly_C-700 Yahoo Group, discussions, fun challenges for all C-7x0 users, http://groups.yahoo.com/group/Oly_C-700/
- Member of the Toronto Camera Club, http://www.torontocameraclub.com/

albireox May 26, 2004 9:31 AM

Thank you very much for your answers. I feel much better now...


All times are GMT -5. The time now is 11:56 AM.