Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   General Discussion (https://forums.steves-digicams.com/general-discussion-11/)
-   -   Wein Safe-Sync with CP 5700 (https://forums.steves-digicams.com/general-discussion-11/wein-safe-sync-cp-5700-a-18386/)

daredevil80 Dec 31, 2003 7:17 PM

Wein Safe-Sync with CP 5700
 
Does anyone have any experience with this adapter in conjunction with Vivitar 285s? Is is reliable enough to not have the flashes fry the camera?

I am considering buying the Safe-Sync, but have heard of some problems with flashes not firing on command. I'd rather be able to use my 285s instead of buying a pair of SB-50DX's!!!

Can anyone help?

KCan Dec 31, 2003 8:16 PM

Re: Wein Safe-Sync with CP 5700
 
Quote:

Originally Posted by daredevil80
Is is reliable enough to not have the flashes fry the camera?

I am considering buying the Safe-Sync, but have heard of some problems with flashes not firing on command.

I never used any of Wein product , but I guess it's safe enough.
On the other hand, I am curious about those problem you heard about.

JanetKP Dec 31, 2003 9:47 PM

Dare devil, I'm not sure my situation is relevant, but Santa gave me wide angle lens for my Canon, and discovered (as many have) that I had a dark area where the wide angle lens blocked the auto flash.

Fortunately, I am a Canon SLR owner, and used my 'old' Vivitar flash gun on my Canon G2.

Voila!!! No shadows and the flash gun is in sync with the camera.


All times are GMT -5. The time now is 10:45 AM.