Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Sep 28, 2006, 12:23 PM   #1
Senior Member
 
Join Date: Mar 2004
Posts: 546
Default

I got a Pentax K100D from Beach Camera about two weeks ago. They had a great price and even with the free shipping I still received it in one business day. After using the camera for about a week, I realized that there was a dot showing up in my photos. I know it was probably just dust on the sensor, but it didn't budge when I used the air puffer on it. I didn't want to try a "wet" cleaning on a brand new camera, so I called Beach Camera and explained the situation. They said, "No problem. Just send it back and we'll ship out a new one."

I shipped it off to them on Monday (3 days ago). I just received my brand new replacement camera an hour ago! Now that's customer service!
gadgetnut is offline   Reply With Quote
Sponsored Links
Old Sep 30, 2006, 5:02 PM   #2
Junior Member
 
Join Date: Sep 2006
Posts: 4
Default

That's really good to hear!I ordered a Nikon D50 from them last Monday, upgraded the shipping by one step, and it arrived yesterday (I'm on the west coast) and I am so far quite pleased. I hope I don't have to return it, but I'm happy to hear a good experience!
qarin is offline   Reply With Quote
Old Sep 30, 2006, 11:00 PM   #3
Senior Member
 
Join Date: Mar 2004
Posts: 546
Default

Yeah, I was happy.Not only did they doeverything quickly, but they were very friendly on the phone too. It's that kind of service that will bring me back again. And I'll recommend them to other people as well.
gadgetnut is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:21 AM.