Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Dec 27, 2006, 7:55 PM   #1
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Hi, I bought an Aosta DV310 a few months ago worked fantastic and I loved everything about it. The last time I played with it I drained the battery so it needed recharging but I was pre-occupied for a little while and it was left on the shelf for about 6 weeks, when I eventually came to charge it it wouldn't work, the light that usually turns red when charging stayed green as though it was fully charged and when I pushed the power button (whilst still plugged into the charger) the light would go red (camera would not start up) once red I left it to charge for a few hours but nothing happened. Just wondering if anyone else has had this problem? or if any of my actions caused it?

After a lot of work trying to find what battery it takes I've found it takes an NP60 and I'm waiting delivery of the new battery, even though I don't know if that's the problem just hoping
:?

LiccleMadam is offline   Reply With Quote
Sponsored Links
Old Dec 29, 2006, 6:29 AM   #2
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Well, my information was wrong the battery needed is not an NP60 (Too big) but luckily Aosta have just mailed me back and tell me the battery it takes is the same as the battery that goes into a Nokia 8210 phone and now I'm waiting for delivery for that one, was hoping to be snapping away again by new years eve, don't think that's going to happen now
LiccleMadam is offline   Reply With Quote
Old Dec 29, 2006, 12:19 PM   #3
Senior Member
 
Morag2's Avatar
 
Join Date: Jun 2006
Posts: 820
Default

I hope your new battery works alright. If that is not the problem, then I'm afraid I can't help much. I haven't even heard of Aosta before:-)
Morag2 is offline   Reply With Quote
Old Dec 29, 2006, 12:34 PM   #4
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Well this is what it looks like, from what I've read on here it goes under a few other names, Hanshing I think one was.

LiccleMadam is offline   Reply With Quote
Old Jan 29, 2007, 7:13 AM   #5
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

New battery came and it works fine. so I'm finally snapping away again, some lovely family footage on it too which was nice to find.

I've had mail recently someone wanting to know how to contact Aosta so I thought it might be easier to just post it here save future people needing to ask.

http://www.aosta.com.tw

2F-2, No. 716, Jhongjheng Road,
Jhonghe City, Taipei County 235, Taiwan
Tel : +886 2 8227 8286
Fax: +886 2 8227 8406

Sales: [email protected]
Technic Support: [email protected]

P.S If your trying to mail them please try a couple of times, seems they have a spam filter and some mail doesn't get through, also an idea to fax them.
LiccleMadam is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:57 PM.