Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Jan 30, 2007, 11:19 PM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

every time I try and turn on the camera it just blinks.. like up top it bilnks orange and green, i have a SP-350 Olympus and it doesnt on. ive tried putting a new battery. what should i do?
samihassan is offline   Reply With Quote
Sponsored Links
Old Jan 31, 2007, 1:01 AM   #2
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

:| some1
samihassan is offline   Reply With Quote
Old Jan 31, 2007, 8:15 AM   #3
Senior Member
 
Ronnie948's Avatar
 
Join Date: Oct 2002
Posts: 721
Default

I would think it needs repair, take it to where you purchased it if it is not to old and see what they think.

Ronnie
Ronnie948 is offline   Reply With Quote
Old Jan 31, 2007, 9:18 AM   #4
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Blinking orange and green is indicative of a depleted battery. What type of battery are you using? If using a fully charged battery, and the condition persists, check to see if the battery contacts in the camera are clean and free of corrosion.

the Hun

rinniethehun is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:15 PM.