Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Aug 7, 2003, 2:34 AM   #1
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default Argus DC1510

I just bought a new digicam. It worked fine all day...but then tonight when i took some pictures...and i tried to download them onto my computer....it said there was no pictures in the camera itself....i am at a total loss...i have tried everything to get it to work....could anyone suggest anything??...please
jamieb is offline   Reply With Quote
Sponsored Links
Old Aug 7, 2003, 4:32 AM   #2
Senior Member
 
Join Date: Aug 2002
Posts: 1,910
Default

Did you at any point remove the batteries after taking the pictures? Since this is a lower end camera and it doesn't use memory cards, it might need batteries in it at all times to keep the pictures intact until you download them.

Also since you said you just got it, did you maybe by accident erase the pictures?

You have to give yourself time to get used to the controls of any digital camera...I know when I had a camera like yours I too erased some pictures.

Hopefully someone else will have an idea.

A great site for Argus 1500/1510 questions, http://askthecoach.apte.com/topic.cfm?topic_id=7
Mike_PEAT is offline   Reply With Quote
Old Aug 9, 2003, 2:47 PM   #3
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default

no I didn't take the batteries out at all...i plugged in the USB cable to the camera....i just used it like an hour before that....i have had other digi cams and never had problems...so i am not sure what is wrong...i have tried everything...and even tried contacting Argus...but have not gotten a reply yet...
jamieb is offline   Reply With Quote
Old Aug 9, 2003, 2:51 PM   #4
Senior Member
 
Join Date: Aug 2002
Posts: 2,162
Default

Try their website:

http://www.arguscamera.com/

Curiously, if you read the manual, it suggests the camera may 'lock up' and opening the battery door resets it. So since it saves to SDRAM, my guess is opening the door wipes your pics - but check this out!

However, it can pull power from the usb connector, so when you get the low blinking batt warning, I'd turn the thing off ASAP and find a pc to download. Note the handbook says use AA Alkaline batts, but I'd stuff in 1800mAh NimH batts and get a charger, making sure you put in a fresh charged set each time you use it.
voxmagna is offline   Reply With Quote
Old Aug 9, 2003, 10:49 PM   #5
Junior Member
 
Join Date: Aug 2003
Posts: 3
Default

Mike...thanks...i got my camera working...they had the problem at that website...i did as said and all is up and running again....it is greatly appreciated...
jamieb is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:46 PM.