Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Sep 17, 2007, 4:36 PM   #1
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

A freind brought me a Fuji FinePix A330 to see if I could help him. He has a 512MB xD card and when he shoots he gets a "write error" alarm. I did all the standard things like formatting and cleaning contacts but no luck. I tried the 512MB card in my Olympus C-5050 and was amazed to discover it worked perfectly. Naturally I then assumed his camera was in trouble. To double check I tried a 32MB xD card that I wasn't using in his camera it also worked fine! Now I'm flat out of ideas. How is it possible? His camera works fine on my xD card. My camera works fine on his xD card but his camera doesn't like his xD card. (And his manual says up to 512MB is OK).

Can anyone suggest what is going on here?

Thanks

John
John Van Allen is offline   Reply With Quote
Sponsored Links
Old Sep 17, 2007, 4:47 PM   #2
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Yes John, his manual says up to 512MB is OK...however, when the manual was written, they were referring to the original xD cards. Subsequently, Fuji and Olympus introduced the 'M' series and 'H' series xD cards. These are not compatible with the A330. However, all is not lost. If the camera has one of the following serial numbers:

A330 Serial No. 4A******,4B******,4CA50175 or younger,4CL45446 or younger,4J******,4K******,4LL0****

...a firmware update is available, which will make the newer cards work in the A330. Just go here:

http://www.fujifilm.com/products/dig...port/download/

Good luck...hope it works out.

the Hun

rinniethehun is offline   Reply With Quote
Old Sep 17, 2007, 5:12 PM   #3
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

Thanks. The camera has 4BB24581 S/N so I'll follow your suggestion

Regards

John
John Van Allen is offline   Reply With Quote
Old Sep 29, 2007, 7:30 AM   #4
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

Hi:

Just thought you would be interested to know that I downloaded the firmware upgrade to my lap top then double clicked it to get the Upgrade format then sent it to an old xD card via a card reader/writer. Then I moved the xD card to the FinePix camera and followed the upgrade steps and BINGO it now works perfectly on the newer xD cards.

Thanks again

John
John Van Allen is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:34 AM.