Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Oct 30, 2007, 3:51 PM   #1
Junior Member
 
Join Date: Oct 2007
Posts: 5
Default

I've got a Sony Cyber-shot Digital Still Camera DSC-T1 which I've been using for last couple of years but all of sudden it has stopped working. I can't say for sure what caused it to fail 'cos I always take good care of it and I keep it in its original leather bag at all times. When I was going to take some pictures last week I noticed that it was broke. Here's a quick overview of what I have observed / done:
  1. The OSD is fully functional.[/*]
  2. The screen still shows the OSD correctly.[/*]
  3. Instead of seeing the actual object, it shows purple / grey / white lines.[/*]
  4. Taking a picture at daylight captures the same as what is seen on the screen as in 3.
    [/*]
Samples of how it looks are available here:
  1. http://users.telenet.be/ravefiend/DSC00001.JPG[/*]
  2. http://users.telenet.be/ravefiend/DSC00004.JPG
    [/*]
Attempted:
  1. Another battery[/*]
  2. Another memory stick[/*]
  3. Reset the camera
    [/*]
Questions:
  1. What could be the cause of this kind of behavior?[/*]
  2. Is it worth looking at a repair?[/*]
  3. What's the best channel to get it repaired? Sending it straight over to Sony? (I live in Belgium)
    [/*]
Any comments or tips are appreciated!
Ravefiend is offline   Reply With Quote
Sponsored Links
Old Oct 30, 2007, 7:24 PM   #2
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

Sounds like a CCD failure. Go here:

http://forums.steves-digicams.com/fo...mp;forum_id=28

the Hun

rinniethehun is offline   Reply With Quote
Old Oct 31, 2007, 1:28 AM   #3
Junior Member
 
Join Date: Oct 2007
Posts: 5
Default

That is quite interesting for sure so thanks for the tip Hun! I'll be getting in touch with Sony as soon as possible to confirm that this is the problem.

Update: here's an interesting site describing the problem in more detail, as well as the affected models:
http://www.imaging-resource.com/badccds.html#cause

Ravefiend is offline   Reply With Quote
Old Dec 9, 2007, 2:24 PM   #4
Junior Member
 
Join Date: Oct 2007
Posts: 5
Default

Final words on this: Sony has replaced the CCD without any costs (warantee) so thumbs up, as it works even better as before!
Ravefiend is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:18 PM.