Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Mar 14, 2008, 9:48 PM   #1
Junior Member
 
Join Date: Mar 2008
Posts: 7
Default

so i got my new casio exilim s700 off ebay today, and everything is cool except it wont turn on. its been on the carger for hours, when plugged into the usb it pops up on my computer. I even know the screne works cause one time when i took it of the carging cradle it had a message, "no media items" or something like that. When it in the cradle and i press the power button the usb light comes on, and my comp tries to find any media on the camera. when on the cradle and i push the power button the indicator light on the camera flashes, but when its not in the cradle the indicator light dose not flash. so basicly everything works but it just wont turn on. am i doing something wrong:?
[img]chrome://piclens/content/launch.png[/img][img]chrome://piclens/content/launch.png[/img]
smacigidsevets is offline   Reply With Quote
Sponsored Links
Old Mar 14, 2008, 10:38 PM   #2
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,572
Default

Does the camera have an SD card in it?
TCav is offline   Reply With Quote
Old Mar 14, 2008, 10:47 PM   #3
Junior Member
 
Join Date: Mar 2008
Posts: 7
Default

no it dosent, the guy i got i from said it came with one but there wasnt one in the box, i already messaged him about it. but would the SD card make a difference?
[img]chrome://piclens/content/launch.png[/img][img]chrome://piclens/content/launch.png[/img]
smacigidsevets is offline   Reply With Quote
Old Mar 15, 2008, 2:27 AM   #4
Senior Member
 
Join Date: Jun 2005
Posts: 804
Default

I'm betting that t would make a difference. The camera can't do anything without a media card, so maybe it figures what's the point of turning on with no card in place?

Although you'd think that instead of doing nothing it would display some message on the lcd like, Please Insert SD Card.

Do you have an owners manual? You can download casio manuals here:

http://world.casio.com/qv/download/en/manual/

They seem to list almost everything except the s700, but, I bet that the s600 is so close that that most of what the s600 manual says will be applicable to the s700 -- at least as far as how to get it turned on.

I think that there's still a Casio forum on this site. If you keep having trouble, people there might be in a better position to provide a good answer.

Grant
granthagen is offline   Reply With Quote
Old Mar 15, 2008, 3:46 PM   #5
Junior Member
 
Join Date: Mar 2008
Posts: 7
Default

yes i do have the, manuals, i ampretty sure the battery is bad. the manual says it take about 2 hours to get a full charge, but its been on the carger for over 12 and it is still flashing red, meaning charging. What i dont understand though is that last night i put it on the charging cradle without a battery and i let me set the date but when i pressed ok to confirm it the screen just went black.

Maybe its just me, for some reason my minolta slr never wanted to work right for me either, but would work right for others...lol
[img]chrome://piclens/content/launch.png[/img][img]chrome://piclens/content/launch.png[/img]
smacigidsevets is offline   Reply With Quote
Old Mar 15, 2008, 8:57 PM   #6
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

A flashing red light usually means a charging error, not that it's charging. If it had been charging for 12 hours, your camera probably would have blown up by now. Sounds like you have a bad battery.

the Hun

rinniethehun is offline   Reply With Quote
Old Mar 16, 2008, 10:03 AM   #7
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,572
Default

It sounds increasingly to me like you should just pack it up and send it back, and hope you get your money back.
TCav is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:43 PM.