Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Sep 23, 2012, 1:23 PM   #21
Super Moderator
 
peripatetic's Avatar
 
Join Date: Nov 2004
Posts: 3,599
Default

Thanks all.

Yes, I've also had a "Super Moderator" outfit made, so let's keep the title the same for a while. At least until I've had a chance to wear it a few times.

P.S. After a long saga I now have my website back on line. With woefully little new content this summer - it's true. But I'll be trying to update it soon. Maybe even tonight!!

Mostly it's been a dreadful summer for photography, and I've just been really busy with kids and swimming.
__________________
My gallery
My X100 blog
peripatetic is offline   Reply With Quote
Old Oct 7, 2012, 1:47 PM   #22
Senior Member
 
Join Date: Jun 2002
Location: Victoria, B.C., Canada
Posts: 943
Default

Hear, hear!
Herb is offline   Reply With Quote
Old Nov 4, 2012, 1:16 AM   #23
Senior Member
 
hkmp50's Avatar
 
Join Date: Oct 2010
Location: USA
Posts: 1,370
Default

Congradulations Craig, Hope to see some help on my newest camera if you dare...
__________________
The hardest part of accepting criticism is realizing I am not perfect.......
hkmp50 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:41 PM.