Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Feb 7, 2004, 11:02 AM   #1
Junior Member
 
Join Date: Feb 2004
Posts: 1
Default Olympus C750: loosely fixed lens tube

Is it normal that for Olympus C750 UZ cameras to have loosely fixed lens tube? I've just got one and notice that the lens tube is not tightly fixed to the camera body. Actually, when I turn it around upsidedown, I soft of :x hear the lens tube slide back. With the lens cap on, I can also feel the wobbling motion of the lens tube when I lightly tap the cap. What is going on? Is it a bad unit that I have got? :roll:
victor is offline   Reply With Quote
Sponsored Links
Old Feb 7, 2004, 11:21 AM   #2
Senior Member
 
Join Date: Sep 2002
Posts: 3,585
Default

No you do not have a bad unit. This is the way the zoom lens was engineered.
gibsonpd3620 is offline   Reply With Quote
Old Feb 8, 2004, 12:36 AM   #3
Senior Member
 
Join Date: Jan 2004
Posts: 824
Default

If you're worried about damaging it, you can get a rigid filter adapter that screws onto the body and will serve the additional function of protecting the lens--but it does add some protrusion to the front of the camera when you try to store it.
Norm in Fujino is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:47 PM.