Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Apr 29, 2017, 11:15 AM   #1
Junior Member
 
Join Date: Apr 2017
Location: Poulton Le Fylde, Lancs, England
Posts: 1
Default Nikon Coolpix P610 issue

I purchsed th ebove camera around a year ago, and overall I just love it, BUT, it has one really nasty habit I am hoping others in the forum can help me with.

Every time I recharge the battery (using the approved Nikon white plug, white cable etc charging unit), it seems to charge up just fine, and using it after a charge, it seems to carry on working just as I would expect it to work.

However, my real problem, and it is driving me nuts, is that as soon as I lay the camera aside (do not use it) for a day or more, I can absolutely GUARANTEE that the battery will be TOTALLY FLAT the next time I pick it up.

Now we all know that continuously recharging modern batteries is not that good for them, so I cannot just leave it on charge all the time it is not actually being used, but that is the only way I can guarantee that if I decide to go out and shoot some pictures or video, my camera is actually ready for use.

I just cannot believe this is correct, or indeed part of the camera design ? The camera is just great for my usage, and I love it to death, but this problem is something that is almost drivingme to sell it on and get something that will still be "ready for use" when I pick it up a few days after it's last brief use. I also have two of those cheap " chinese clones" of the famous GoPro brand cameras, and they keep their charge for literally months, often surprising me by the fact they are still ready for use, even after sitting on a shelf for several months.

Can anyone suggest what the problem may be. The camera has NOT been overused by any means, and I would estimate I have only recharged the battery around 100 times in total, so again do not believe that it is "knackered" from a hard life

I really would like to resolve this issue as rapidly as possible, as it is causing me several problems right now due to this lack of what appears to be battery stability. ??

Last edited by chopperaddict; Apr 29, 2017 at 11:21 AM. Reason: added "gopro" info
chopperaddict is offline   Reply With Quote
Sponsored Links
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:08 PM.