Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old May 25, 2004, 10:41 AM   #1
Junior Member
 
Join Date: May 2004
Posts: 2
Default

Well, I bought my Olympus C750UZ a few days ago. Everything seems fine, I'm happy with the picture quality so far. But I notice somethig pretty strange. The objective of the camera shakes a little, just like it wasn't fixed right. Is that a problem with my camera or is something common with any ultra zoom camera.
Thank you!
albireox is offline   Reply With Quote
Sponsored Links
Old May 25, 2004, 11:17 AM   #2
Senior Member
 
Join Date: Jan 2004
Posts: 397
Default

albireox wrote:
Quote:
Well, I bought my Olympus C750UZ a few days ago. Everything seems fine, I'm happy with the picture quality so far. But I notice somethig pretty strange. The objective of the camera shakes a little, just like it wasn't fixed right. Is that a problem with my camera or is something common with any ultra zoom camera.
Thank you!
style="BACKGROUND-COLOR: #666666"http://www.stevesforums.com/forums/v...;highlight=750

Take a look at the above thread.There may be others if you do a search in the Olympus forum.


Puck M is offline   Reply With Quote
Old May 25, 2004, 4:39 PM   #3
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

There are many messages on this subject in the Olympus forum...the lens wiggle is perfectly NORMAL and nothing is wrong; the lens is designed to "float" in the assembly.

Most C-7x0 users will recommend using a filter adapter tube with a UV filter on the camera at all times to not only protect the lens from dust and scratches, but from also being bumped out of alignment.

- Check out the Oly_C-700 Yahoo Group, discussions, fun challenges for all C-7x0 users, http://groups.yahoo.com/group/Oly_C-700/
- Member of the Toronto Camera Club, http://www.torontocameraclub.com/
Mikefellh is offline   Reply With Quote
Old May 26, 2004, 8:31 AM   #4
Junior Member
 
Join Date: May 2004
Posts: 2
Default

Thank you very much for your answers. I feel much better now...
albireox is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:35 PM.