Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Sep 19, 2004, 3:02 PM   #1
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

Hello everyone, I'm Chris in Tampa, FL, new to this forum and I thought it would be a cool place to talk with others that have the same interest as I do. I originally started with Sony Digicams in 2001 when I bought my first DSC-P1, I thought it was awesome to be able to take unlimited pic's for free. I got some average pic's with my P1, then moved up to the smaller DSC-P5 and then i was hooked. Shortly after my P5 i bought a DSC-S85, DSC-P9, DSC-U20, DSC-F707 andDSC-F717. More recently i purchased a DSC-P52, DSC-P72, DSC-P92, DSC-P10, DSC-V1,DSC-P93, DSC-P100, DSC-T1, and DSC-W1. I have sold some of them on ebay but I still have a bunch. (Posted here so you know I'm not making it up) These are the cams I currently own plus the T1 i still have which I took the picture with. So, if you have any questions, comments or just want to share your experiences with these cameras, my contact info is in my profile. (I mostly use AIM)
Attached Images
 
CyberShotNut is offline   Reply With Quote
Sponsored Links
Old Sep 20, 2004, 5:17 AM   #2
Member
 
judell74's Avatar
 
Join Date: Aug 2004
Posts: 78
Default

I envy you! You got a lot of investment there dude!!!
judell74 is offline   Reply With Quote
Old Sep 20, 2004, 6:38 PM   #3
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

I don't really consider it an investment considering the second you break the seal on the box it's only worth about 75%. To me it's more of a hobby and I have always been interested in comparing the different models, sizesand photo quality between them. I'll have to say, of all the Sony cameras I ever owned, the only one that truely disappointed me is the T1, aside from it's small, slim size I can't really say much good about it.It's way too expensive for what it is. The slowest shutter speed on the T1 is 1 sec. which is no where near slow enough to take goodnight scene shots, plus there is no tripod mount. Compared to the 2.5" W1 display, the T1 has a double the pixels but it is a hybrid display which is dimmer and the colors are not as accurate. As just about everyone has stated in their reviews, the flash is almost useless. Aside froma tripod mount, I don't see much improvement in the upcoming T3. The V3 looks like another story, any upgrade to the V1 will be awesome considering that the V1 is an exceptional camera as it is. I want to try that one out as soon as soon as it becomes available.
CyberShotNut is offline   Reply With Quote
Old Sep 20, 2004, 10:50 PM   #4
Junior Member
 
Join Date: Sep 2004
Posts: 16
Default

So, . . . you must have alot of pictures somewhere, right? Chris I'm in tampa, too. Post some local pics so I can copy them and say I took them.

Just kidding. I like seeing pictures other people take of places I know. I'm considering the new P150 when it comes out, I've always owned Canon's till now. I loved the shutter lag ( or lack of lag) on the Sony P100 I tested. And you can't beat the size.

What's the least favorite feature, the one you never use?

Have you ever used the marine pack, or any of the converter lenses with your cams? What do you think of them?

Thanks, Holly.
hsuthard is offline   Reply With Quote
Old Sep 21, 2004, 1:59 AM   #5
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

Hello, the only conversion lens I have is the VCL-HGD758 1.7X telephoto lens for my F717, it works excellent at full telephoto, but has some dark spots at less than full telephoto zoom. I don't own any marine packs, but amthinking aboutgetting one for my P93. Considering I keep my cameras on full resolution 99% of the time, the feature I use the least would have to be the smart zoom. I just posted a few of the thousands of pic's I have on my hard drive. Take a look, some of the pic's may be familiar to you if you live in Tampa.:arrow:http://photobucket.com/albums/v477/CyberShotNut/
CyberShotNut is offline   Reply With Quote
Old Sep 22, 2004, 12:36 AM   #6
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

Oops, typo.. The lens I have is VCL-HGD1758 not VCL-HGD758.
CyberShotNut is offline   Reply With Quote
Old Sep 22, 2004, 10:49 AM   #7
Senior Member
 
atlantagreg's Avatar
 
Join Date: Jun 2002
Posts: 243
Default

Ok.. now this is a sickness. LOL... now WHY would you buy several P-series 5MP models?? Hmmmm... Doctor!! :?

You should also check out www.mavican.nu as it's full of Sony people.


atlantagreg is offline   Reply With Quote
Old Sep 22, 2004, 4:58 PM   #8
Senior Member
 
CyberShotNut's Avatar
 
Join Date: Sep 2004
Posts: 673
Default

I've just gotten awesome deals on them that I couldn't pass up.After testing them out for a while, I usually resell them on ebay...
CyberShotNut is offline   Reply With Quote
Old Oct 20, 2004, 3:24 PM   #9
Junior Member
 
Join Date: Oct 2004
Posts: 2
Default

Chris,

Have you or anyone hear of issues with the DSC-T1 display. My wife had hers for 7 months andjust found out that the display is cracked. We use the case (tripod ready) and she swears she did not drop it. And to make it worse, the Sony authorized repair says its not covered.

Thanks,

Randy :?
RandyJ is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:44 AM.