Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Apr 30, 2005, 12:30 PM   #1
Member
 
Saycheez's Avatar
 
Join Date: Apr 2005
Posts: 84
Default

I bought a Canon Powershot G6 last Sunday...and it has a white line horizontally across the LCD screen. I am wondering if this is a fault in the screen? Also last night I started hearing a funny whirring /sort of light beeping noise ..when I looked in the book it said that a noise from the camera could be normal..but it just started making it last night and only does it when I have the LCD screen on and working...help (newbie here and to digitals:?)
Saycheez is offline   Reply With Quote
Sponsored Links
Old Apr 30, 2005, 11:52 PM   #2
Member
 
Saycheez's Avatar
 
Join Date: Apr 2005
Posts: 84
Default

Well took it back and they gave me a brand new camera..the manager looked at it and the salesclerk..both said they had never seen that before..I am just happy to have a camera again.
Saycheez is offline   Reply With Quote
Old May 1, 2005, 2:54 AM   #3
Senior Member
 
Join Date: Nov 2004
Posts: 935
Default

The whirring noise could be autofocus, as long as it isn't a continual whirring noise. The HORIZONTAL line doesn't sound normal at all, so it was nice that they gave you a brand new replacement camera.
Kenny_Leong is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:45 AM.