Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Jan 1, 2003, 8:59 PM   #1
Senior Member
 
Join Date: Sep 2002
Posts: 135
Default Nikon 2500 Locked up Can't Shut off

My 2500 was working great until today, when I was shooting photos inside and it stopped responding.
The LCD display stayed on, I could see everything the lens was showing, but the menus could not be brought up, it would not power off when the slide switch was in the off position.
Even when I put the switch in the play position, it still stayed in the camera mode, nothing seemed to work.
No zoom, no scene change, nothing except it stayed in the shotting mode, but it would not take any pictures.
I could not shut it off, I had to take out the battery, put it back in and it worked fine after that.
The card is ok, has room for 122 more pictures on that 128mb card.
This happened this morning, after I took out the battery it worked great the reat of the day.
Do I have a bad camera?
Has this ever happened to anyone else?
Thanks in advance for any information you may have.
Bill
Bill Benson is offline   Reply With Quote
Sponsored Links
Old Jan 1, 2003, 9:24 PM   #2
Senior Member
 
Join Date: Aug 2002
Posts: 1,910
Default

I don't know that camera specifically, but most would suggest taking out the batteries overnight to let the camera reset to its factory state (note that any presets in the camera will be lost).
Mike_PEAT is offline   Reply With Quote
Old Jan 2, 2003, 1:21 AM   #3
Senior Member
 
Join Date: Jun 2002
Posts: 668
Default

Bill Benson,
1X is a fluke, 2nd is warrenty issue.
Gary
Gary Senkus is offline   Reply With Quote
Old Jan 2, 2003, 7:10 AM   #4
Senior Member
 
Join Date: Sep 2002
Posts: 3,585
Default

I agree with Gary, contact dealer support and ask them what is going on. Look at their web site for FAQs.
gibsonpd3620 is offline   Reply With Quote
Old Jan 2, 2003, 6:06 PM   #5
Senior Member
 
Join Date: Sep 2002
Posts: 135
Default

Thanks guys, it only happened once so far, but I called Nikon and the tech asked what kind of CF card I was using, I told him PNY 128mb.
He said Nikon does not support PNY only Lexar and Sandisk, he also said this may or may not be my problem but to try another card.
If it happens again with the PNY card, I will try the card that came with the camera or my Sandisk card.
The camera is working great so far.
Bill
Bill Benson is offline   Reply With Quote
Old Jan 3, 2003, 10:23 AM   #6
jaf
Junior Member
 
Join Date: Jan 2003
Posts: 2
Default

:roll:
We are having the same problem with a Nikon Coolpix 885. It hangs quite a lot, but if you take off the battery and restart, it works OK.
Maybe a bug in the camera? We're using the original memory card bundled.
jaf is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:58 PM.