Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Nov 27, 2005, 11:27 AM   #1
Junior Member
 
Join Date: Nov 2005
Posts: 24
Default

just bought a Nikon D50... I've taking some pictures, but in the clear ones, there is always a black spot on the upper left side of the picture... I don't know if it's the camera that is damaged or if the lens have dirt... i tried to clean the outside of the lens, but the spot keeps appearing...


The camera is new... if someone could help me... thanks.


Steve
Attached Images
 
CCtrader is offline   Reply With Quote
Sponsored Links
Old Nov 27, 2005, 12:20 PM   #2
Senior Member
 
Join Date: Jan 2004
Posts: 824
Default

Could be a big blog of dust on the sensor.
Norm in Fujino is offline   Reply With Quote
Old Nov 27, 2005, 12:28 PM   #3
Senior Member
 
rjseeney's Avatar
 
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398
Default

That's most likely sensor dust. You can clean the sensor yourself if your comfortable and have the right tools. Just google sensor cleaning and you should be able to find suppliers and tools. If you're not comfortable, you will have to send the camera to an authorized Nikon center for service. Make sure when you change lenses to do it in a dust free environment. Also make sure the camera is powered off and the lens mount is facing down. Only keep the lens off long enough to mount the new one...this will minimze the chances of getting dust on your sensor. Inevitably, all DSLR's will eventually need sensor cleaning....one of the drawbacks of the format.
rjseeney is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:26 PM.