Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Reply
 
Thread Tools Search this Thread
Old Feb 27, 2006, 2:59 PM   #1
Senior Member
 
Join Date: Sep 2005
Posts: 126
Default

Just got my first ballhead and have a couple of questions. When using in portrait position, the camera tilts more than 90 degrees down. Also, weight and gravity always makes the camera slip and shift on the threads in portrait position. Is this normal? Thanks!
B1ue is offline   Reply With Quote
Sponsored Links
Old Feb 27, 2006, 3:34 PM   #2
Senior Member
 
Join Date: Dec 2002
Posts: 5,803
Default

Which ballhead did you get? That would help a lot in giving you some answers.

I have an Arca Swiss ball head (I got it used) and it doesn't have these problems.

Eric
eric s is offline   Reply With Quote
Old Feb 27, 2006, 3:52 PM   #3
Senior Member
 
Join Date: Sep 2005
Posts: 126
Default

I bought a Giotto MH 1003 which I have tested on a couple of different 'pods. Small and relatively light, but maybe the machining isn't as precision as it should be?
B1ue is offline   Reply With Quote
Old Feb 27, 2006, 10:00 PM   #4
Senior Member
 
Join Date: Dec 2002
Posts: 5,803
Default

On the surface that doesn't look like a bad ballhead, but I've never used it.
Its only rated for 8.8lb. What are you mounting on it (Camera, lens, flash... in other words, are you going beyond the suggested weight limit)?

It might not be "machining isn't as precision as it should be" (as you put it so well.) Which would be sad, but possible.

Eric
eric s is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:20 PM.