Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   H-P (https://forums.steves-digicams.com/h-p-23/)
-   -   Dead HP 735 (https://forums.steves-digicams.com/h-p-23/dead-hp-735-a-57922/)

DMike Jun 9, 2005 10:01 AM

I wasusing my HP-735 and after taking a series of pics the "red Screen" of deathappeared and then the camera went dead. I tried to reboot it but nothing worked. Irecharge4 batteries and replaced them 2 at a time, butthatdid not solve my problem. Thelens is stuck in the extended position andthe camera does not come on at all. The only thing is that whenI put in thefully charged batteries theleft back side of the panel gets warm. I suspect that I may have a bad circuit. I eventually relented and sent it in to Radio Shack for repair. Has anyone elseever experienced this problem with their HP camera. And would you know that this happened themonth after my oneyear warrenty expired.

ssmith Jun 20, 2005 6:04 AM

The very same thing happened to me just 3 days after my 12 month warranty expired

proton Aug 18, 2005 10:09 AM

yes, I had the same problem and my sister had a digital camera of another brand, with also the same problem! Seems like a thing that is not just happening with H.P.

I went to the shop and within 2 weeks my camera was replaced! The guy in the shop also mentioned someone else with that problem who also brought his camera back. After the replacement I had no problems anymore, using the new replaced camera since January 2004 now without any jam.


All times are GMT -5. The time now is 5:47 PM.