Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Dec 23, 2007, 2:17 AM   #1
Junior Member
 
Join Date: Dec 2007
Posts: 3
Default

I am a new owner of the A-HD. I like the picture quality but the battery only lasts 15 min. I only get 10-15 min of continious recording time with a fully charged battery. Is the normal or is there something wrong with my camera. I am interested to hear what other people get.
floppy2 is offline   Reply With Quote
Sponsored Links
Old Dec 23, 2007, 6:07 AM   #2
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,621
Default

Foppy welcome

1 is the hybrid new what color.

2 was the battery charged fully 3-5 hours is the charge time 90 minutes average is the record on time

3. battery can be a dud, it happens try a new battery,

4 what battery is in there

5 try a test 3 aa and match polarity up

hope that helps

if you can a return and exchange ,befire you do make sure the firmware isto your liking and you got Arcsoft if you get a dud in a camera on t5he next. I be mad:idea:
fishycomics is offline   Reply With Quote
Old Dec 23, 2007, 10:01 AM   #3
Junior Member
 
Join Date: Dec 2007
Posts: 3
Default

Thanks for the reply.

It's the blue one from. Got it friday from CC. It has the 1.6 firmware.
I have charged it overnight >8 hours, but still only 15 min recording time. I tried another np-60 battery from a kodak point-and-shoot and it's about the same thing. At least I get 30 min with 2 batteries .:-)
So 90 min is what i should normaly get ?
Really like the camera, takes a lot better video than my old JVC DV and only costs $99 after rebate. But 15 min recording time makes it almost useless for me.
floppy2 is offline   Reply With Quote
Old Dec 23, 2007, 11:36 AM   #4
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,621
Default

are you sure it is the A-Hd. I say it is a decision of an exchange you'll get an even swap. your choice.
fishycomics is offline   Reply With Quote
Old Dec 27, 2007, 3:40 PM   #5
Member
 
Join Date: Jun 2005
Posts: 57
Default

floppy,

Sometimes my battery acts goofy like that. When you see it "red", pull it out and re-insert it. It should show green again.

Not sure what's up, but I've seen that issue, but still get over an hour on my battery....
webshark3 is offline   Reply With Quote
Old Dec 29, 2007, 11:31 AM   #6
Junior Member
 
Join Date: Dec 2007
Posts: 3
Default

I exchanged it at CC for a different unit.
All is good now, getting over one hour battery time.


floppy2 is offline   Reply With Quote
Old Dec 29, 2007, 12:42 PM   #7
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,621
Default

when my batt is on full I know I am goodto go, but when I see it on the last line I know it istime to change. I have filmed 20 minutes on the lst red. saying when is it going to exhaust a spare is always good to have it fits in the coin pocket
fishycomics is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:45 AM.