Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Apr 12, 2008, 3:50 PM   #1
Junior Member
 
Join Date: Apr 2008
Posts: 1
Default

Hello !

I have a Slimneo XV11 PROSIO and after few years of good duty, the LCD went black.
Opened the beast and the ribbon cable from the mainboard to the LCD is torn....cannot be repaired...triple layer ribbon...:?

So I have been looking for the part (which P/N is 001-04230L-A10 A3) everywhere through retailers, even tried to contact the manufacturer...no luck

Any idea where i can find such a part ?

THANKS IN ADVANCE !!!!!!

Cheers !


Attached Images
 
michok is offline   Reply With Quote
Sponsored Links
Old Apr 12, 2008, 5:36 PM   #2
Senior Member
 
Join Date: Mar 2003
Posts: 3,200
Default

I think it's cheaper (and faster) to buy a new camera then to search the whole world for this cable (you nowhere will get)
DonalDuc is offline   Reply With Quote
Old Apr 12, 2008, 6:34 PM   #3
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

Company name iI was lookingfor was Ipix.

http://www.globalsources.com/gsol/I/...1004336948.htm

Globalsources.com this is a clone or orginator try a lil research thre on the site , you'll have some contacts good luck

fishycomics is offline   Reply With Quote
Old Apr 13, 2008, 10:28 AM   #4
Senior Member
 
Join Date: Mar 2003
Posts: 3,200
Default

Minimum Order:
[*]1,000 to 1,999 Unit [/*]
for camera !

Perhaps he get a cable, if he orders 10.000 to 19.999 cables ?
DonalDuc is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:07 PM.