Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Apr 1, 2009, 9:06 PM   #1
Junior Member
 
MFlanders's Avatar
 
Join Date: Mar 2009
Posts: 21
Default

Mine does not and if it is a common malfunction I may not bother returning it for a replacement.


MFlanders is offline   Reply With Quote
Sponsored Links
Old Apr 2, 2009, 12:59 AM   #2
Junior Member
 
Join Date: Apr 2009
Posts: 3
Default

I've found mine to be very accurate based on what's in the manual.

What exactly are you experiencing?

Sometimes, it may report low(25% full) when you turn it off but then show moderate(~50%) when you turn it back on. It should only show that moderate temporarily(it should jump back to low if you attempt to record anything or shoot a picture) and I always interpret it as the battery life being between those two power levels. That's the only thing I've seen on mine that can be interpreted as being odd and from my experience with electronics, that's pretty normal. :G


eyeonwashparish is offline   Reply With Quote
Old Apr 2, 2009, 5:41 AM   #3
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default



Double the Welcome people...........

Battery life or idications that I know of are and abnormal.

Fully charged Battery:

1 camera on. and beating the controls to the screen will get you a "LOW BATTERY" a icon on thescreen dead center. Most will not admitt this here, a manafacturer defect FLAW. yes not just one cam I own.

2. while in a on position, and hitting record any time, getting a LOW BATTERY ICON dead center of the screen, forcing a missed shot, and hitting record not once...............

BAttery Level Indicator:

while the batt ind. is at full the batt should last give or take 60 minutes. longer when not filming HD1080P, HD702P, SHorter when filming HD720P, and even shorter with HD1080P. Stills w/o flash longer, with flash shorter, and all varies with the amount of time we use the cam and in standby.

What will happen when the Indicator lowers levels:

at full you film, and may drop and flicker between full and 1st level. and in standby, jump back to full. continued operations. next level and repeat to in the LOW level, when it hits its lowest level, the cam will decide to say:

I have reached my limit of power, toss a LOW BATTERY ICON saving your file, and shutting down the camera.

I am sure ittakes about two minutes after Low battery to save file toss a EXHAUST ICON, turn off.

I hope some of this info to our viewers who tend to skip a manual, and go directly to playing witht he cam.

hope this helpped out a lil.



MFlanders wrote:
Quote:
Mine does not and if it is a common malfunction I may not bother returning it for a replacement.

fishycomics is offline   Reply With Quote
Old Apr 2, 2009, 7:46 AM   #4
Junior Member
 
MFlanders's Avatar
 
Join Date: Mar 2009
Posts: 21
Default

Thanks,I have had it show an empty battery a couple of times when battery was fully or almost fully charged. Didn't get any message in the screenscenter. That was when taking short clips and it has also shown full battery once after using it for about forty minutes which was the only time I have used it that long.

Also have it showing about a quarter empty when fully charged on occasion.

I didn't see anything in the manual,will look again. I also can't seem to find any manual that was on the installation disc.
MFlanders is offline   Reply With Quote
Old Apr 2, 2009, 5:13 PM   #5
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

the E-manual and online PDF will show a page about battery , and batt life.

Asking what firmware may or may not be the problem, but may never know

if you're expeirencing battery lndicater spasms then it may be said you got a falty cam with a badbios chip, as well as I ............
fishycomics is offline   Reply With Quote
Old Apr 4, 2009, 9:00 PM   #6
Junior Member
 
MFlanders's Avatar
 
Join Date: Mar 2009
Posts: 21
Default

Is there a way to identify what firmware it came with?

Also,as it seems you have tried many different firmwares and have problems with your meter also,did one of them correct the problem?

Thanks
MFlanders is offline   Reply With Quote
Old Apr 5, 2009, 6:52 AM   #7
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

I do not have a issue with te Meter I have a issue with the ICON on most models.

1 turn on cam

2 press MODE once displays the setting camcorder my works voice

3. HOLD DOWN Mouse over three secs, and DO NOT let go. PRESS SHutter still FULLY IN

Firmware displays. then you can let go. After you read and wantto get back hit MODE again done

let us know the FW
fishycomics is offline   Reply With Quote
Old Apr 5, 2009, 5:45 PM   #8
Junior Member
 
MFlanders's Avatar
 
Join Date: Mar 2009
Posts: 21
Default

Followed your directions and Pressed and held camera shutter. It took a picture and displayed "charging".No numbers.

Pressed and let go,nothing.



No biggie,battery goes dead it goes dead. Just would be nice if it worked correctly. And with all the views and lack of comments,I think I will return it for a replacement.

Thankyou for your efforts fishycomics. Much appreciated.


MFlanders is offline   Reply With Quote
Old Apr 6, 2009, 4:02 PM   #9
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

in youtube i do show a video on exactly how easy it is to do it

sometimes it takes morethen one try. it takes me one or many.........

best bet is to return , for an exchange.

today I hitthe record 5-6 times before getting the video and yes you and I are the only interested ones, while there are many out there that just complain directly to a company.

I hear ya.
fishycomics is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:33 PM.