Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Nov 29, 2011, 5:24 AM   #11
Junior Member
 
Join Date: Nov 2011
Posts: 2
Default Aiptek full hack!!! HELP!!! AHD M12 Extreme example

I'm not sure is this the right place to post this but I need help!

This will be long.. I fully hacked my brand new Aiptek but i went too far and spoiled it. Here is some multiple questions. What this all means? I'm really trying to make the camera better. It can do much more that it says in descriptions. No AV in and Mono mic.

http://www.aiptek.com.tw/c0_1.php?bid=2&cid=5&pid=48#02

There are hidden buttons in the machine. They depend from your model. But usually they are almost the same. We need to do like Aiptek Pro manual or manual part 2.

Here you can find all manuals and updates: ftp://ftp.aiptek.de/

To update: Put your update to memory card. Press M(menu). Hold Joystick up for at 3 seconds then press shutter (still pictures) and hold together with joystick up.

To disable auto off: Press M(menu). Press Mode, hold it down 3sec, then press shutter (still pictures) and hold it down. (I don't know what this was suppose to do? But i made the hardware hack for my screen. See below.)

To check firmware version: Press M(mode), hold it down, then press Play, hold it down, and then press shutter button (for still pictures) and hold it down.

Firmware settings:

Model: VAZ2S (128M) = Model
FW ver: 2002 = Firmware version
lib:a5-1.0-20100524 = ?! + Date
Date: Oct 22 2010 = Date of the FW?
Time: 11:45:17 = Time of the FW?
Update: sd_vaz2.bin = Firmware update
Sensor : MICRON10M = Object?
Gyro:Pa_ewts98c = Gyro sensor
Panel : TP3.0 16:9" = Screen size/aspect ratio
Avin : NONE = AV IN or AVI?!
Audio : WAU8822 = Sound
SW_SCALAR(2): 1(4) = ?!
Calibration Info
BadPix :1 = ?!
LensCalib : 0 = Lens?!
VigCalib : 1 = ?!
WBCalib : 1 = White Balance
AFCalib : 1 = Auto Focus
EIS Shake : 1 = Electronic Image Stabilizer (E.I.S)
EIS Still : 1 = Electronic Image Stabilizer (E.I.S)
IRIS Calib : 1 = Iris
MShutter : 1 = Shutter
BLC : 1 = Backlight Compensation
Production Info
Date: 2011-08-01 = Camera manufacturing date?!
Time: 10:16:36 = Camera manufacturing time?!
Line_Num: L6 = Production line?!
Worker_Num: W0000 = Worker number
Level: 1 = ?!
WPN: MIP-110700141 = Product number


To enable hidden features: Check firmware version. On your model press right! (This is the "secret". In your model it might be left or rec (red dot) etc.)

There you can unlock the mp3 player, net camera, Adjust ALL calibration and stuff that i cant explain Here is the extra menu:

Debug Off/On = What is this?!

Test Mode Off = Caution! Explained under.
Factory *
Engineer **

PCCam Off/On = PC Cam! (stays on)

MP3 Disable On/Off = Mp3 Player!! (disabled after shutting off)

Amba Cam Off/On = What is this?! (disabled after shutting off)


Here is the danger options where i ruined my camera :/ You need to move carefully. In AHD H12 E, the moving buttons are Mode=Forward, M=Back. M is also TEST! It tests the action you look. You can move up and down from joystick. And make actions by pushing it. Rec=Cancel!
If you calibrate something in test, you can't get it back! That's where i need help, how to calibrate this thing?
Some of the settings go away when you turn off or take battery out. But not calibrations
I need to test if updating helps.

Put the Test mode on and go back (push M):

* Factory

Main Menu
-Calib
Vidgette
WBC
BadPixel
AFC
EIS
EIS_Shake
EIS_Still
IRIS
Mshutter
BLC
BadPix White
BadPix Black
-Test
Flash1
FlashWithCount
Key
IR
TFT Color
Video
Audio
RTC
Storage
Format
LED
WhiteLED
Run in Test
-Test OZ
Lens Test
Focus Test
Zoom Test
Wide Test
Tele Test
LS Test
LENS ADJUST
LENS Check
Wide Tele Test
-Erase Pref
Erase Pref


Flash1
-StoreJPG
No/Yes
-Flash
On/Off/Auto

FlashWithCount
-Count
1/10*/500/3000
-StoreJPG
No/Yes
-Flash
On/Off/Auto

WBC
-StoreJPG
No/Yes
-StoreRaw
No/Yes
-Flicker
60Hz/50Hz

Key
-Automatic!

IR
-Automatic!

TFT Color
-Automatic!

FlashWithTime
-Time
1-10 (5*)
-StoreJPG
No/Yes
-Flash
Off/Auto/On
-Resolution
3/5*/10/12

BadPix White
-Automatic!

BadPix Black
-Automatic!

WBC 2800K
-Automatic!

WBC 6500K
-Automatic!

Vignette
-Automatic!

Erase Pref
-Automatic!

Video
-Automatic!

Audio
-Automatic!

BadPixel
-Automatic!

Format
-Automatic!

RTC
-Automatic!

Storage
-Automatic!

LED
-Automatic!

WhiteLED
-Automatic!

AFC
-Automatic!

EIS
-Automatic!

EIS_Shake
-Automatic!

EIS_Still
-Automatic!

Lens Test
-Automatic!

Focus Test
-Automatic!

Zoom Test
-Automatic!

Wide Test
-Automatic!

Tele Test
-Automatic!

LS Test
-Automatic!

Run in Test
-Count
43/85*/128/170

IRIS
-Automatic!

Mshutter
-Automatic!

BLC
-Automatic!

LENS ADJUST
-Automatic!

LENS Check
-Automatic!

Merge calib
-Automatic!

Wide Tele Test
-Automatic!



** Engineer - Test Mode

DPC(Amba)
-BlackGain
0-30 (21*)
-Flicker
60Hz/50Hz
-WhiteTh
10-200 (30*)
-WhiteNum
1-6*
-BlackTh
10-200 (100*)
-BlackNum
1-6*

AHWBC
-Automatic!

RAW
-Store JPG
No/Yes
-Type
Still/View-FHD/View-HD/All
-Flicker
60Hz/50Hz
-Disable3A
No/Yes
-Explosure
127/132*/137/142/147..245/250/255
-Agc
0-127 (31*)

AMBA-RAW
-Type
Still/PHOTO/QVGA/VGA/WVGA/HD-30/HD-60/FHD

JPG
-Automatic!

CTC
-Store RAW
No/Yes
-Flicker
60Hz/50Hz
-Store JPG
Yes/No
-Flash
No/Yes
-BlockSizeX
100-600 (250*)
-BlockSizeY
100-600 (400*)

AFC
-Automatic!

EIS_Shake
-Automatic!

EIS_Still
-Automatic!

LST
-Automatic!

Vignette
-Automatic!

ERASE
-Erase
all/pref/calib
-id
All/AF/CC& Vig/WB/BadPix/EIS/IRIS/Msutter/BLC

Battery Life
-Automatic!

IRIS
-Automatic!

MSHUTTER
-Automatic!

BLC
-Automatic!

Lens Sort
-Automatic!

Calibration Info
-Lens
off/AF/EIS/MShutter/Iris/All
-Sensor
off/Viggnette/BadPix/All
-AAA
off/WB/ISO/BLC/All

SD_Speed
-Automatic!




There it is. After my camera did some automatic calibrations there is now dead pixels in picture (not in the screen). And there is like "burned" image shadows in the picture How can i calibrate this and make the settings better? I understand that i have to buy some kind of color tablets and other calibration gear to do that?

I noticed that my FW had changed:
BadPix went from 1 to 2, and WBCalib from 1 to 2.





Here is some extra mod's that i made for my camera. They work very well but my warranty went off..:

Lens ring mod: http://www.instructables.com/id/Add-...H12-Camcorder/

Screen close mod: http://www.livevideo.com/video/E5E47...era-mod-1.aspx
In AHD H12 E the magnet was between the left mic and the screen. And it was glued hard. I think the microphones could bee moved or changed if you want. Its stupid that they are there. Its possible to make output from mics too. I have to test the sound more. It's enough if you get the two black screws in the screens side. I took off all the screws under the screen and one from under, screen side.

Battery mod: http://www.youtube.com/watch?v=ZP_2512467Y
I haven't done the battery hack yet. I don't know how or can i connect my extra batteries some way?
Leso is offline   Reply With Quote
Old Dec 16, 2011, 12:02 PM   #12
Senior Member
 
Wayne12's Avatar
 
Join Date: Jun 2006
Posts: 1,071
Default

http://forums.steves-digicams.com/hy...ps-aiming.html

Last edited by Wayne12; Dec 16, 2011 at 12:09 PM.
Wayne12 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:08 PM.