Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Mar 3, 2010, 9:42 AM   #1
Junior Member
 
Join Date: Mar 2010
Posts: 8
Default Please help me Speed SV800 DV

Hey

I have no idea if this forum can help in specific technical problems of digital cameras but I really don't know what to do. I recently brought a digital camera from another country. It's a Speed 8 MegaPixels, SV800 MPEG4 Digital Video Camera. It came with a battery and a battery charger which I charged and is currently fully charged. It has internal built in memory. I put the battery inside the camera but the camera just won't turn on at all. I connected the camera to the laptop and I installed the driver from it's software CD on the laptop but no matter what I do, the camera won't turn on. The battery charger indicates that the battery is fully charged. What should I do? I live in Egypt, and I didn't buy the camera from here and I won't be travelling to that other country anytime soon. There's no retail shop here for Speed brands. I searched all over the internet. Their official website speed-jp.net is really useless, it doesn't even have a place for troubleshooting.

Please help me, it would be greatly appreciated. Thank you.
Areej is offline   Reply With Quote
Sponsored Links
Old Mar 3, 2010, 8:20 PM   #2
Senior Member
 
VTphotog's Avatar
 
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,214
Default

I am not familiar with the brand, so probably can't be of much help except to as a few questions. How certain are you that the battery is charged? Have you measured the voltage? Is there a possibility the battery can be inserted backwards - and if so, have you tried to reverse it? Is the power switch a button or a slide switch, and are you able to 'feel' it making a contact?
Last, can you return it for exchange, since it appears to be dead on arrival?

brian
VTphotog is offline   Reply With Quote
Old Mar 3, 2010, 9:07 PM   #3
Super Moderator
 
Hards80's Avatar
 
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046
Default

moved it to the hybrid camcorder section, more likely to find someone with experience here.
Hards80 is offline   Reply With Quote
Old Mar 4, 2010, 3:11 AM   #4
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,621
Default

battery has a very lil tab or slotm they as well have a arrow, aligning up the batt to the pins.

does thepins match, not bent do they look like they will make contact.

When usb on pc and cam plugged in does anything occure, like pc recognising, you may have to pres or open or turn on cam

battery on most today are not needed to do this.

if cam does not turn on DEAD on arrival like the above poster says

store bought, no reciept, no number and out of country,, I say google, streetmap any map site , grab the info that is provided and do your best in contacting via phone, get a phone card cost pennies.

and see if thathelps in cotnacting , I understand purchasing and getting stuck hurts, but do not let this be a damper.

not trying to sound like a bad person, i look for the same model order and get the info from that person. to contact company. or exchanging .
__________________
These are Pc low Budget Economy Hybrid camcorders Great for the Daytime Outdoor shots
Light on the Object video made. No light No Video
fishycomics is offline   Reply With Quote
Old Mar 5, 2010, 9:26 AM   #5
Junior Member
 
Join Date: Mar 2010
Posts: 8
Default

Quote:
Originally Posted by VTphotog View Post
I am not familiar with the brand, so probably can't be of much help except to as a few questions. How certain are you that the battery is charged? Have you measured the voltage? Is there a possibility the battery can be inserted backwards - and if so, have you tried to reverse it? Is the power switch a button or a slide switch, and are you able to 'feel' it making a contact?
Last, can you return it for exchange, since it appears to be dead on arrival?

brian

Thank you very much for your reply. In answer to your questions:

- I'm pretty sure the battery is fully charged, I guess the only case that the battery wouldn't be charged, is if the battery charger would turn out to be not working, but I really think it is working because it has light indicators that work and everything.
- I'm sure the battery is placed correctly and not in reverse. I haven't measured the voltage, any suggestions on how I can do that?
- The power switch is a button and I'm sure that I'm clicking on it and its making contact, I don't think its a case of the power button not working.

I don't think there's any chance of me being able to return it, because it's from another country that I won't be going to again.
Areej is offline   Reply With Quote
Old Mar 5, 2010, 9:29 AM   #6
Junior Member
 
Join Date: Mar 2010
Posts: 8
Default

Quote:
Originally Posted by fishycomics View Post
battery has a very lil tab or slotm they as well have a arrow, aligning up the batt to the pins.

does thepins match, not bent do they look like they will make contact.

When usb on pc and cam plugged in does anything occure, like pc recognising, you may have to pres or open or turn on cam

battery on most today are not needed to do this.

if cam does not turn on DEAD on arrival like the above poster says

store bought, no reciept, no number and out of country,, I say google, streetmap any map site , grab the info that is provided and do your best in contacting via phone, get a phone card cost pennies.

and see if thathelps in cotnacting , I understand purchasing and getting stuck hurts, but do not let this be a damper.

not trying to sound like a bad person, i look for the same model order and get the info from that person. to contact company. or exchanging .
Thank you very much for your reply.

- I'm sure the battery is placed correctly and alligned against the pins with all pins looking in perfect condition
- When i connected to laptop i tried switching it on, and it didnt respond as well
- I will try to get more information about the company to contact them about my problem
Areej is offline   Reply With Quote
Old Mar 5, 2010, 8:44 PM   #7
Junior Member
 
Join Date: Mar 2010
Posts: 22
Default

do you have multimeter to check voltage on battery? maybe the charger doesn't charge the battery?
Anndybo is offline   Reply With Quote
Old Mar 5, 2010, 10:11 PM   #8
Senior Member
 
VTphotog's Avatar
 
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,214
Default

Another possibility which occurs, is the AC voltage where you live the same as where you bought the camera? If the charger is set for a higher voltage, it would light up, but not charge the battery correctly.
If you can get access to a voltmeter, it would tell you the battery voltage. If you don't have one, you should be able to go to an electronics store and have someone check it for you.

brian
VTphotog is offline   Reply With Quote
Old Mar 6, 2010, 6:58 AM   #9
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,621
Default

battery are 3.6-3.7vdc.

If you are handy you can make your own little battery mod.

AA's , AAA's or any 3.7 vdc battery and some wire.............

3 store bought batts add to 4.5vdc
3 rechargables add to 3.6vdc

What exactly does the charger say?

most cams are for regional, if your region is 110, 220, then the battery charger should be of that voltage 110, or 220

the output of the charger would be 5.0 vdc...........

I do not think your battery would be different, 3.6 will run, 3.7 will run and all the way to 5.0, placing in 6.0vdc would be the highest and 3.0 be the lowest
__________________
These are Pc low Budget Economy Hybrid camcorders Great for the Daytime Outdoor shots
Light on the Object video made. No light No Video
fishycomics is offline   Reply With Quote
Old Mar 19, 2010, 9:39 AM   #10
Junior Member
 
Join Date: Mar 2010
Posts: 8
Default

i finally fixed it, thanks alot for all your help. turns out there was something wrong with the charger and the battery wasnt charging because of that. i got a new charger and now my camera works just fine =)
Areej is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:53 PM.