Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old May 5, 2011, 4:24 PM   #1
Senior Member
 
Join Date: Jul 2006
Location: The Villages, Florida, USA
Posts: 128
Default Why "jerky" playback in Elements, but smooth playback in Movie Maker

Ok, so I downloaded a couple of HD video clips (mov) to Elements 9.0 and they played very jerky.

I looked around for solutions at the Elements web site and only found things that accused my hardware of being substandard.

For the heck of it I opened the same files on the "free" Movie Maker that came with my System 7. They played perfectly. No jerks.

So what's up with Elements and movie playback? You would think a program I Paid $$$ for would work better than a freebie.
gfmucci is offline   Reply With Quote
Sponsored Links
Old May 5, 2011, 5:39 PM   #2
Junior Member
 
Join Date: Apr 2011
Posts: 17
Default

maybe because elements 9 need more system resources to run
acmx is offline   Reply With Quote
Old May 5, 2011, 6:34 PM   #3
Senior Member
 
Join Date: Jul 2006
Location: The Villages, Florida, USA
Posts: 128
Default

Quote:
Originally Posted by acmx View Post
maybe because Elements 9 need more system resources to run
If that is the case, that makes Adobe Elements pretty lame, being a resource hog worse than a free program that comes with Windows 7.

So the question becomes, why did thay make Elements 9 require excessive resources, when the job can be done better with fewer resources (Movie Maker)?
gfmucci is offline   Reply With Quote
Old May 5, 2011, 6:44 PM   #4
Junior Member
 
Join Date: Apr 2011
Posts: 17
Default

yeah elements is alot bigger program and require more resources to play smoothly, im not familiar with elements but try lowering the preveiw quality


http://www.adobe.com/products/premiereel/systemreqs/
acmx is offline   Reply With Quote
Old May 5, 2011, 8:52 PM   #5
Senior Member
 
Join Date: Jul 2006
Location: The Villages, Florida, USA
Posts: 128
Default

How many "resources" should Elements require? I have a 4 gig desk top with plenty of hard drive space and a decent video card. I never have had a problem playing any downloaded video from the web, including HD.

I was considering purchase of Adobe Premier Elements to supplement my Elements 9.0 to process my video files from my new Fuji, but upon experiencing the poor performance of Adobe compared to other products, I'm scratching that bad puppy off my list - unless someone can show me how I have Elements set improperly to run these short (1 to 2 minute) video clips.

Last edited by gfmucci; May 5, 2011 at 8:57 PM.
gfmucci is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:00 AM.