Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Jan 19, 2006, 6:52 AM   #1
Junior Member
 
Join Date: Jan 2006
Posts: 3
Default

I have purchased what I now know is a Hybrid. It is a EuroCyber DDV-777X. It came with a CD Rom that had U Lead Software and supposingly a device driver. I installed the driver connected the usb lead and my pc (win XP home edition sp3) will not recognise it.

I have tried teh same on my work pb (win PE, sp 2) and it recognised it as a DDV 660 and installed a driver. It shows it as a removeable device but at least I can read the SD (1gb) card.

Can any one help me with adriver, I have googled DDV and eventually found this site.

I hope you can help me
Can the Man is offline   Reply With Quote
Sponsored Links
Old Jan 19, 2006, 12:01 PM   #2
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

you have win xp home edition sp3 on the system that failed? then its a driver issue and will not be fixed until the developer of the driver updates accordingly. Microsoft is a proffesional at breaking continuity/drivers as well as creating more problems.

if it's not an sp3 issue, can you elaborate exactly on "it will not recognize it?" what exactly does the os tell you?

if you want, you can msn me [email protected] I can help you debug your system
Cresho is offline   Reply With Quote
Old Jan 19, 2006, 9:29 PM   #3
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

Welcome to the forum, Can the Man,

Much as I dislike Microsoft's operating systems, I don't think that's the problem.

How are you connecting the memory card to the computer? Using an integrated or external card reader, or using the camera with the usb cable? I've found when doing the latter, sometimes the cable isn't quite connected properly. Seems it's a bit tricky.

Do you have a known-good usb port, does anything else work properly using the port and/or cable?

Can you post some specs for the EuroCyber DDV-777X? I googled the name, but couldn't find specific information for that model. If I have some specs, I can tell which Digilife it is. Several Digilife cameras show up on the computer as 660's.

Probably by now, Cresho has fixed it anyway.

sgspirit is offline   Reply With Quote
Old Jan 21, 2006, 5:14 PM   #4
Junior Member
 
Join Date: Jan 2006
Posts: 3
Default

Hi sgspirit,



many thanks for your help and advice. I changed the USB cable and port connection and windows XP reconised it as a mass storage device type DVD-660 and installed the driver for it.

My stupidity.



Thanks again.


With regards the spec
Can the Man is offline   Reply With Quote
Old Jan 21, 2006, 5:15 PM   #5
Junior Member
 
Join Date: Jan 2006
Posts: 3
Default

Hi Cresho,



Thanks for your offer but have a look at my reply to sgspirit



Thanks again
Can the Man is offline   Reply With Quote
Old Jan 21, 2006, 6:24 PM   #6
Senior Member
 
Join Date: Jan 2006
Posts: 1,092
Default

yes, if you plug in the device and windows does nothing, then it's most likely a hardware issue. Glad to see you have it working. I thought "windows did not recognize it" ment, windows identified device and drivers were needed. :lol:
Cresho is offline   Reply With Quote
Old Jan 22, 2006, 11:22 PM   #7
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

Given the camera has image stabilization, it looks like it's the DDV-720. I'll update its entry in the Hybrid List.
sgspirit is offline   Reply With Quote
Old Feb 20, 2006, 8:13 AM   #8
Junior Member
 
Join Date: Feb 2006
Posts: 1
Default

hi, i need help...

i got a ddv-777x cam...when i move house i lost the whole box...so i need a driver for the cam can anyone help...




my email is [email protected]
devil_lord is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:48 AM.