Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Reply
 
Thread Tools Search this Thread
Old Apr 18, 2006, 5:36 PM   #1
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

How do your batteries seem?

Deliveries of the latest DDV-920's were delayed by queenofglitter because they lacked batteries and chargers. Mine has seemed to be getting very little life from the battery since I got it, so I just ran a test. Playing MP3 at 3/4 volume on the speaker, with the screen closed/off.

The battery lasted 30 minutes. This seems unreasonable, especially for a 1100mah battery. I'm trying it now with an older aftermarket battery.

EDIT: The problem was traced to things other than the battery. The battery was fine all along.
sgspirit is offline   Reply With Quote
Sponsored Links
Old Apr 18, 2006, 6:49 PM   #2
Junior Member
 
Join Date: Mar 2006
Posts: 6
Default

I had a problem with battery life too :sad: 15 minutes of video recording before shut down ! So i returned my iSpan to the eBay seller, and he sent me a new one . There were a problem with the battery's connectors inside the iSpan !
With the new one, i can record about 1h30 min of video (with a 1200 mAh battery).
Blutch is offline   Reply With Quote
Old Apr 18, 2006, 6:54 PM   #3
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

Not a good sign, return your battery to QoG and get a new one, but I bet she'll ship a new one no charge



1 1/2 hour is the Playtime period.

you may Pull 2 hours out of it?

have you notified QoG of why you recieved a defective product? I gave up, and rather Purchse a trusted camera on a trusted site over a seller of Ebay



my problem was noted pulled off pkg sticker and Yes we all had opened boxs. to me not to have all its content on thee tells me its refurbished in my eyes?
fishycomics is offline   Reply With Quote
Old Apr 18, 2006, 10:39 PM   #4
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

I'm pretty sure it's not the camera that's at fault. I have a couple of year-old NP-60's I bought separately, and the one I tested this afternoon played mp3's, with the screen closed, for 105 minutes. I suspect that intermittent use could get more time out of it, rather than running it continuously until the battery is exhausted.

The camera came from queenofglitter, so I'll let them know.

As for the camera being refurbished, I can see no sign of that, and I trust the seller that the camera was new. That said, it does seem odd some of the cameras were missing the batteries and chargers. There could be many explanations for this, so I'm not going to speculate.

EDIT: The problem was traced to things other than the battery. The battery was fine all along.
sgspirit is offline   Reply With Quote
Old Apr 19, 2006, 12:12 AM   #5
Member
 
Join Date: Feb 2006
Posts: 90
Default

With my previous 920 (that is no longer in my possession) I remember having quite a good battery life. I'd listen to mp3s from home to school (about an hour ride) and still be able to fool around with it till i got home.

I'll let you guys know how the new one works out. (but damn i miss that old one. I don't recall ever having the "rays" prob either, however i did get some blue tinting in sunlight)
aijuswannasing is offline   Reply With Quote
Old Apr 19, 2006, 1:21 AM   #6
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

Running a business like selling these cameras on eBay must be such a headache for people such as D&K of queenofglitter.
sgspirit is offline   Reply With Quote
Old Apr 19, 2006, 2:54 PM   #7
Member
 
Join Date: Feb 2006
Posts: 90
Default

Hey guys,

I did some tests during my calculus lecture (lol) and got a good forty minutes of recording and still had two bars left. I'm pretty pleased.

Thing is though, after twenty min of recording, the camera will just shut off, and the recorded video "lost." I say "lost" because the record time counterremains decreased, meaning the space int he SD card has been occupied,but no video is accesible in the movies folder. I think it's because the camera had not time to finalize and name the file. I've done a format on the card and will try some more tests.



any1 else incounter something similar?
aijuswannasing is offline   Reply With Quote
Old Apr 19, 2006, 4:33 PM   #8
Moderator
 
fishycomics's Avatar
 
Join Date: Jul 2005
Location: NYC NY
Posts: 9,623
Default

that was , and is still a problem, the sd car d should be fine , no matter what speed.

the recording can either be 1 sec -1 hour and if it does not get buffered out into the file and hangs three things occure

1 you record and the camera shuts down, for no appearant reson

2. the camera records and not finalized, due to low battery, camera being shut off, due to batt removal.

3. sd card removed

There are talks about the connection to the battery being weak, and a peice of tape around the battery will keep in place, not true

the camera door has a metal contact and must make sure it is touching

another way not to lose the file due to low battery is there is no way t olose. the camera will not record due to low battery it'll beep fast, and faster real frequently.

but if the battery is just past the low, it will currupt the file.

How does one retrieve a curupted file. I do not know the answer yet, I am working on why a thumbnail is not displayed? on the MPVr

Sorry t osay

1 bad batteries from Queen of Glitter ( request a new one a.s.a.p.) ( have a list of members that have bad batteries all will get shipped if you get the list together)

2 defective, or refurbished cameras (missing side labels) Must mail back fora exchange or refund

3 pass the camera on.

Sorry I sound Like i was let down

But Prism effect, sd film curuption, poor battery, not good.
fishycomics is offline   Reply With Quote
Old Apr 20, 2006, 12:27 AM   #9
Moderator
 
Join Date: Jul 2005
Posts: 887
Default

Queenofglitter got right back to me and said they're checking with Ispan to see what can be done about the battery.

Tonight, I ran my other aftermarket battery, 70 minutes of recording and playing back, entirely with the screen turned on. So it's in good shape too. I was expecting these batteries to lose more capacity than they have just from aging.

EDIT: The problem was traced to things other than the battery. The battery was fine all along.
sgspirit is offline   Reply With Quote
Old Apr 20, 2006, 1:10 AM   #10
Senior Member
 
Join Date: Jan 2006
Posts: 137
Default

Sgspirit, are you still in the market for an MPVR? Haven't heard you mention anything this week.
RaeRae1981 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:37 PM.