Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Apr 17, 2007, 7:22 PM   #1
Junior Member
 
Join Date: Apr 2007
Posts: 2
Default

Hi.
I have problem with Kodak P850. When i take picture, camera often turns "off" an "on" ......
I have update to firmware 1.01 ...Camera is 1 year old and batery is not changed since that time.
Is it problem With batery...or ???

Pls. If someone knows what is the problem....

sorry for bad english...hope U will understand me.

Tnx....
Damir is offline   Reply With Quote
Sponsored Links
Old Apr 17, 2007, 11:11 PM   #2
Member
 
Join Date: Aug 2003
Posts: 34
Default

it could very well be the battery. i had the same problem when I tried using a generic battery.
aeroshep1 is offline   Reply With Quote
Old Apr 25, 2007, 10:52 AM   #3
Senior Member
 
Join Date: Aug 2005
Posts: 197
Default

Greetings,

Have you tried using a different battery? If you are close to a retailer, you may want to try exchanging batteries to see if the problem persists with a newer fully charged battery.

Have you taken a lot of pictures with the camera or charged the battery many times? Couldn't have been that many times.

Also, when you say the camera turns off and on, what does that mean exactly. Does the screen go blank? Does the camera actually turn off and then on again? Tell us specifically what happens and what you see. What effect does this have on the image you have captured or is the image lost? The more information the better the diagnosis.

Talk to you soon,

Ron Baird
Eastman Kodak Company
Ronbaird is offline   Reply With Quote
Old Apr 25, 2007, 2:15 PM   #4
Senior Member
 
fgreenhut's Avatar
 
Join Date: Jul 2004
Posts: 169
Default

I had the problem where my DX7440 would turn on by itself after being turned off. Nothing semed to help. I finally stoped using it and just used my Z612 till the other day I read of someone with a similar problem who solved it by "Before opening the camera giving the mode dial a pair of quick (without stopping) 100% turns from one end to the other. And it worked!"

I tried it and another poster with the same problem tried it and it worked for both of us. Just try spinning the mode dial back and forth a couple of times and see if it helps.

Fred




fgreenhut is offline   Reply With Quote
Old Apr 26, 2007, 6:50 PM   #5
Junior Member
 
Join Date: Apr 2007
Posts: 2
Default

Yes, the screan goes blank.
lens retrcat.
Picture is saved, and its ok.
LED (indicator) turns off.
Camera actually turn off and then on.
Even with full charged batery...

Yesterday i notice when I move "on" switch only 1-2mm i any direction...this will hapen.
Maybe weak contact on switch.

Thnx.






Damir is offline   Reply With Quote
Old Apr 27, 2007, 8:16 AM   #6
Senior Member
 
Join Date: Aug 2005
Posts: 197
Default

Damir,

I see, sounds like the switch is in need of help. I guess I would consider either being very careful where you have the switch placed or having the camera serviced. If it is that sensitive there is something wrong to make it turn off and on.

If you are here in the US, call 800 235-6325 for service.

Ron Baird
Eastman Kodak Company
Ronbaird is offline   Reply With Quote
Old May 20, 2007, 12:28 PM   #7
Junior Member
 
Join Date: Apr 2007
Posts: 9
Default

I have been having a similar problem with my P880.I turn it on and then it turns off and back on again.Also when I half press the shutter button it turns off and back on again.I have tried 2 different batteries and it still happens.

I bought the camera only 5 months ago.
necrodeathhead is offline   Reply With Quote
Old May 21, 2007, 8:35 AM   #8
Senior Member
 
Join Date: Aug 2005
Posts: 197
Default

Greetings,

Not sure what would be causing this issue? But, as with Damir I would make sure you let us know about it. Call the 800-235-6325 number and they will open a case for you. You can track it and make sure things are as they should be. Let me know what happens if you like.

Ron Baird
Eastman Kodak Company
Ronbaird is offline   Reply With Quote
Old May 21, 2007, 10:18 AM   #9
Junior Member
 
Join Date: Apr 2007
Posts: 9
Default

Hi Ron.Thanks for the speedy reply.How long would it take to get the camera fixed if I sent off.Obviously now the summer is approaching,this is when I need my camera.I wouldnt want it to be away any longer than a month.
necrodeathhead is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:56 AM.