Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old May 11, 2010, 9:56 AM   #1
Senior Member
 
Old Boat Guy's Avatar
 
Join Date: Apr 2010
Location: East Texas
Posts: 362
Default dead flash in P-850

I noticed that the flash is not functioning in my P-850.

When I am using the camera the lightning bolt would seem to indicate that the flash is both enabled and ready to fire but does not fire when the shutter is released. I normally use the P-20 zoom flash when shooting with a flash so I have idea how long it might have been dead.

Here is the question and I hope someone can help. Am I being dumb and missing something in the settings or is the bulb in the flash now DOA?

If it would be the bulb are there replacements available?

Thank you

Steve
Old Boat Guy is offline   Reply With Quote
Sponsored Links
Old May 11, 2010, 11:21 AM   #2
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Steve-

Without camera dis assembly, it really sounds like a wiring problem. The actual bulb rarely burns out in the built-in flash unit. And failure of the built-in flash unit has been a recurring problem as the P-850 has aged.

Sarah
mtclimber is offline   Reply With Quote
Old May 11, 2010, 11:39 AM   #3
Senior Member
 
Old Boat Guy's Avatar
 
Join Date: Apr 2010
Location: East Texas
Posts: 362
Default

Thank you for the reply Sarah.

I looked at the manual and do not see any kind of schematic. Is there one available somewhere so I can find the path on the offending wire?

If the camera was designed to be disassembled to be repaired I feel confident in my ability to do so.

Steve
Old Boat Guy is offline   Reply With Quote
Old May 11, 2010, 1:23 PM   #4
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Steve-

There is most probably a repair manual that Kodak created for their own Service Department, but I have never seen it available outside of Kodak.

Sarah Joyce
mtclimber is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:35 AM.