Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Nov 12, 2011, 6:55 PM   #1
Junior Member
 
Join Date: Nov 2011
Location: Wisconsin
Posts: 3
Default Kodak Z812is problem

Hello,

My wife and I have owned a Kodak Z812is since 2008. We have absolutely loved the camera, and it has been trouble-free until recently.

For the last week, whenever we use the one of the SCN settings, the camera has an glitch. Whenever we move the camera using these settings, and especially when we zoom in or out- the camera will switch in and out of panoramic mode. This has happened a few times when we tried to take video too.

It doesn't happen every time that we use the camera, but maybe about 75% of the time. It doesn't seem to ever happen when using the Smart Scene setting.

We have switched the memory card, reset the camera, and downloaded and installed a firmware update for the camera, but nothing has helped.

Any ideas?
Thanks for any advice or comments.
rclang is offline   Reply With Quote
Sponsored Links
Old Nov 13, 2011, 7:53 AM   #2
Junior Member
 
Join Date: Nov 2011
Posts: 3
Default Kodak Z812is problem

Hello rclang
I own a Z812 and I'm too very happy with it. I usually use it in P mode.
Sorry to hear about the fault. I've never had a problem with mine.
Did you tried to change the settings having switched off the cam ?
Starting from my default setting (P mode) and if I want to take a Panoramic pic, I first switch off the cam, change the setting to Panoramic and turn on the cam again.
Hope this helps.
Gerardo

Zebra at the Temaiken-zoo in Buenos Aires (Z812)
Attached Images
 
DeltaPix is offline   Reply With Quote
Old Nov 16, 2011, 7:28 PM   #3
Junior Member
 
Join Date: Nov 2011
Location: Wisconsin
Posts: 3
Default

Thanks for the reply. We have tried your suggestion, unfortunately the problem persists. We are kinda upset because the camera isn't that old and with a newborn (our first), we don't want to have the headaches of having an unreliable camera. Just yesterday our newborn was doing something really cute, and we wanted to record it using video, but the camera malfunctioned and only recorded about 10 seconds- then changed to panoramic mode and turned off.

While we are upset with this Kodak- we really love the Z-series and have ordered a new Z990. We have owned three other Kodak cameras and none of them had any issues at all (they just became a bit obsolete). We are hoping that this one is a fluke and that our new one will be problem free.

We didn't like how "plasticky" the Z990 is, but it's hard to beat in terms of features. We tried it in a Sam's Club- but found it much cheaper on Amazon.

Thanks again for your reply.
rclang is offline   Reply With Quote
Old Nov 18, 2011, 4:03 AM   #4
Junior Member
 
Join Date: Nov 2011
Posts: 3
Default Kodak Z812is problem

Quote:
Originally Posted by rclang View Post
Thanks for the reply. We have tried your suggestion, unfortunately the problem persists. We are kinda upset because the camera isn't that old and with a newborn (our first), we don't want to have the headaches of having an unreliable camera. Just yesterday our newborn was doing something really cute, and we wanted to record it using video, but the camera malfunctioned and only recorded about 10 seconds- then changed to panoramic mode and turned off.

Sorry to hear that. I would give it a try changing the batteries (The Z812 is a battery-eater). 2 new lithium AA non rechargeable are not expensive and if they work you may keep the Z812 as your back-up cam.

While we are upset with this Kodak- we really love the Z-series and have ordered a new Z990. We have owned three other Kodak cameras and none of them had any issues at all (they just became a bit obsolete). We are hoping that this one is a fluke and that our new one will be problem free.

Hope you will have fun with your new Z990

We didn't like how "plasticky" the Z990 is, but it's hard to beat in terms of features. We tried it in a Sam's Club- but found it much cheaper on Amazon.

Thanks again for your reply.
Best wishes for you and your newborn !
Gerardo
DeltaPix is offline   Reply With Quote
Old Nov 18, 2011, 11:10 PM   #5
Junior Member
 
Join Date: Nov 2011
Location: Wisconsin
Posts: 3
Default

The Z812 was a battery eater with normal or NiMh batteries. We ordered a Li-ion battery as soon as we bought it back in 2008, and it lasted for hundreds of pictures without needing a recharge.

We got our Z990 yesterday, and holy cow does that thing go through batteries. We get about 20 minutes of use before the low-battery indicator comes on. (With NiMh AA batteries) I'm hoping to find alternative batteries that will last longer- I'll try lithium, but that will be expensive if they aren't rechargeable.

Thanks for the good wishes.
rclang is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:25 PM.