Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Jun 29, 2005, 7:05 AM   #1
Senior Member
 
DGehman's Avatar
 
Join Date: Mar 2005
Posts: 319
Default

Just got my DX7630 back from Kodak's Rochester NY service - a question of focus and the usual broken battery clip.

(A bit of background - I adapt my things, and some of those adaptations sail pretty close to precipice of warranty-voiding actions... in this case, I took it on myself to rig up a substitute battery clip...)

Thanks to internal customer advocates at Kodak, my camera's back and fixed, under warranty. A couple of the advocatesintervened when the original technie decided that my camera no longer was covered due to my meddling.

It took some extra days, but I'm pleased by the outcome.

Dave
DGehman is offline   Reply With Quote
Sponsored Links
Old Jun 29, 2005, 7:29 AM   #2
Senior Member
 
Join Date: May 2005
Location: OKLAHOMA
Posts: 200
Default

it is always good to hear about GOOD service,thank you
quinton is offline   Reply With Quote
Old Jun 29, 2005, 10:49 AM   #3
Senior Member
 
Join Date: Apr 2005
Posts: 696
Default

Dave, your story about good service is a pleasure to hear.

Pablo
alandjo is offline   Reply With Quote
Old Jun 29, 2005, 10:50 AM   #4
Senior Member
 
kashka's Avatar
 
Join Date: Apr 2005
Location: Minnedosa Manitoba
Posts: 1,158
Default

Dave..I agree..they were outstanding with service when I first got my camera.I lost the plug for the charger..they sent me a free one within a week.I've been sold on the ever since.
lisa
kashka is offline   Reply With Quote
Old Jun 29, 2005, 12:52 PM   #5
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

Makes me feel better about my choice of Kodak for my return to photography.



Dawg
bigdawg is offline   Reply With Quote
Old Jun 29, 2005, 4:01 PM   #6
Senior Member
 
dan279's Avatar
 
Join Date: Sep 2004
Posts: 1,896
Default

Glad it worked out DG

Dan


dan279 is offline   Reply With Quote
Old Jun 29, 2005, 7:31 PM   #7
Senior Member
 
Join Date: Jan 2005
Posts: 1,299
Default

It's nice to hear of good service for a change. I've been toying with the idea of sending my 6490 in, but about the time I decide to it starts taking great pics again.

Bob
Bob Mevis is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:01 PM.