Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Mar 8, 2006, 5:01 PM   #1
Junior Member
 
Join Date: Mar 2006
Posts: 4
Default

Please let me start by saying that I am a purist and a geek. I don't install crappy software like "Easyshare" on my computer. Instead, I use a file manager to move my images to wherever I need them to be.

So, I used to have a 2MP Kodak camera, about 2 years old model, and when I would connect it to my Windows machine via USB, it would mount its internal memory as an external "drive" on my MS Explorer. It worked like a charm. I could delete, copy, paste files and images back and forth with it. I have used 4-5 more digicams with Windows and they all worked as I describe above.

Today, I got a Kodak V550 (latest firmware installed, 1.0700) and this ability does not work correctly anymore. The camera does connect to Windows and I can open its internal memory folder with MS Explorer, and I can even delete files in it. BUT, I can't copy or move files to my Desktop or elsewhere anymore. Also, I can't PUT a file on its internal memory either. Which is rather strange behavior, because one of the the firmware upgrade instructions of the V550 do say that you can place the firmware file on the internal memory and upgrade your camera.

Please note that I CAN use MS Explorer's menu action "transfer pictures" to transfer my pictures, this works. But I can't do it anymore with drag-n-drop or copy/paste. Also, if I click the "copy this image" link from Explorer's sidebar, nothing happens. So, it seems that the USB mounting is half-working.

At the long last I had to actually install the latest Easyshare software 5.2, but when this piece of cr*p is installed, the V550 is not visible anymore AT ALL from MS Explorer. Yes, Sync and Transfer of files does work with Easyshare too, but I don't like it how it disables the camera from the MS Explorer completely. That's why I hate such software that come together with gadgets: they take decisions for me, they cr*p all over Windows and change default MS settings, without asking me.

I have now removed the EasyShare software again, and I can see the camera mounting on MS Explorer again. But as before, I can delete files and use the "Transfer" function of Windows, but I can't drag-n-drop or copy/paste files IN or OUT of the camera manually.

Please note that Mac OS X does not mount the camera at all. iPhoto works just fine with it, but I can't use the camera with the Finder file manager.

So, what's wrong here? Any ideas how to fix this? The "Properties" dialog of the device on Windows does not provide any useful actions for this particular problem.
Eugenia is offline   Reply With Quote
Sponsored Links
Old Mar 8, 2006, 6:52 PM   #2
Junior Member
 
Join Date: Mar 2006
Posts: 4
Default

ok, I called Kodak and they told me to click "Custom" when I try to install the EasyShare software and ONLY install the "Connection Software" driver and not the rest of the applications. After I did that and I rebooted, I was able to mount the camera PROPERLY. However, there is a catch.

In a perfect world, this driver should not be necessary, because what it did was to remove the camera from Windows' hardware list of "cameras", and instead "fool" the Windows subsystem that this is an external drive and not a camera. There are good and bad sides about this decision from the person who designed this driver. The good thing is that I now can move files around as I wish, as I could with other, older, cameras.

The bad thing is that when the camera mounts, Windows does not treat it as a "camera" anymore, and so a bunch of hidden files and folders are now visible. Additionally, the camera can not be used as a web camera anymore, because Windows doesn't see it as one with the new driver. Anyways, I think I will keep that driver anyway, as it does what I need most (moving files around), even if it "cheats" to get there.

Other cameras don't require special drivers, they work out of the box...
Eugenia is offline   Reply With Quote
Old Mar 8, 2006, 7:18 PM   #3
Junior Member
 
Join Date: Mar 2006
Posts: 4
Default

As a conclusion, let me say that the Kodak V550 camera is just buggy. The "Transfer"
utility on Windows and the iPhoto on Mac OS X work because they use a DIFFERENT protocol to get the pictures out of the camera.

But when it comes to their direct mass-storage implementation is buggy (Mac can't mount the camera, and Windows can't copy files in and out of it).

OR, (nasty guess) they tried to fake a mass-storage implementation that didn't expose the entire filesystem, and that's nearly impossible so they got it wrong. And their driver just kinda fixes what their USB firmware screwed up by doing so.

No matter how you see it, if you are one of the people who doesn't want to use the EasyShare software, you are screwed with a driver or not. Yes, you can kinda take your pictures out of the camera, but the full functionality of mass storage or Imaging device connected to an operating system is just not there.

I wonder how is it possible to not find these bugs during testing. And I am not talking about the testing Kodak people, but the engineers themselves.
Eugenia is offline   Reply With Quote
Old Mar 8, 2006, 8:54 PM   #4
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Eugenia-

I use my kodak V-550 with a standard chip reader and it works just fine for me.

MT
mtclimber is offline   Reply With Quote
Old Mar 8, 2006, 9:00 PM   #5
Junior Member
 
Join Date: Mar 2006
Posts: 4
Default

What is a "chip reader"? I am talking about the INTERNAL MEMORY here, I am not talking about SD cards and SD card readers.
Eugenia is offline   Reply With Quote
Old Mar 9, 2006, 12:19 AM   #6
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

Well they are different but saying that I never use the internal memory at all. The card is just so much more convienient. I know there is some internal memory but since on my DX6490 it's only 16 mb It's not ever been worth using for anything so I just never use it and don't have problems with it!

Dawg
bigdawg is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:09 PM.