Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Mar 16, 2006, 5:14 PM   #1
Member
 
Join Date: Nov 2004
Posts: 31
Default

Have a Kodak CX7330 and when I turn the camera on, the status light flashes green once, then flashes red a few times. The lens does not protrude, nor does the camera respond to any of the buttons. The light stops flashing after awhile. Looked in the manual and it only has the troubleshoot for a flashing orange light, not a red. Any thoughts? I have new duracell batteries in it, so I don't think it that. I took the memory card out and turnedit on, same thing happens. I don't have the AC adapter so I can't try that.Any help is appreciated.
MOG_22 is offline   Reply With Quote
Sponsored Links
Old Mar 16, 2006, 9:00 PM   #2
Senior Member
 
bill2468's Avatar
 
Join Date: Dec 2004
Posts: 1,936
Default

Sounds like its time to call Kodak

800/235-6325



Good luck



BiLL

:|
bill2468 is offline   Reply With Quote
Old Mar 17, 2006, 1:03 AM   #3
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

I second what Bill said!

Dawg
bigdawg is offline   Reply With Quote
Old Mar 17, 2006, 9:01 PM   #4
Member
 
Join Date: Nov 2004
Posts: 31
Default

Bill, BigDawg, thank you for your responses.





So no one has had this experience before?
MOG_22 is offline   Reply With Quote
Old Mar 17, 2006, 9:18 PM   #5
Senior Member
 
bill2468's Avatar
 
Join Date: Dec 2004
Posts: 1,936
Default

Just started using Kodak digitals in 2004.

Dx7440 now out of commision

Z7590 just bought it at end of Dec. 2005

Z730 just ordered it today

Like I recomended first try calling Kodak then go to Google and try digital camera repair and see what you can find in your area.

BiLL

:|

If you use the search at the top of this page put in your camera and see who posted a thread about it and post your question there and hope for the best.

bill2468 is offline   Reply With Quote
Old Mar 17, 2006, 9:55 PM   #6
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

I'm just sorry we couldn't give you a more cheerful response. Sometimes the facts are the facts and you have to tell someone the hard truth! Again I'm so sorry we couldn't help more!!

Dawg
bigdawg is offline   Reply With Quote
Old Mar 18, 2006, 12:52 PM   #7
Junior Member
 
Join Date: Dec 2005
Posts: 26
Default

MOG_22 wrote:
Quote:
Have a Kodak CX7330 and when I turn the camera on, the status light flashes green once, then flashes red a few times. The lens does not protrude, nor does the camera respond to any of the buttons. The light stops flashing after awhile. Looked in the manual and it only has the troubleshoot for a flashing orange light, not a red. Any thoughts? I have new duracell batteries in it, so I don't think it that. I took the memory card out and turnedit on, same thing happens. I don't have the AC adapter so I can't try that.Any help is appreciated.
A friend of mine with a CX7530 noticed this behavior when the batteries did not provide enough power to the camera. Try with other batteries, or even better with some rechargeables. It may happen thatbatteries straight off the shelf are already discharged. In very cold weather even half-charged batteries may not provide enough power. Other than that, it looks like a power-related problem...

Ken
kdc41 is offline   Reply With Quote
Old Mar 19, 2006, 2:24 PM   #8
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

Good point Ken!

Dawg
bigdawg is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:20 AM.